First they ignore you
then they ridicule you
then they fight you
then you win
    -- Mahatma Gandhi
Chinese => English     英文 => 中文             
随笔-219  评论-1047  文章-0  trackbacks-0

RoR遭遇严重的安全危机! story 报道了RoR的一个严重的安全漏洞,致使开发者不得不迅速推出一个安全补丁的版本,而且该版本需要强制升级。


  这样的官方发布的安全问题,可谓是给RoR狂热扑了一盆大冷水。RoR的开发者们甚至吓得都不敢公开的这个错误。然而这个错误只是一个开始,还远远没有结 束。从windows,j2ee,php任何开发都经历过这个过程。而他们都趋于稳定,尤其是j2ee,php在unix下的安全架构更是非常可靠,我们 积累了大量这个领域进行防范的经验。



Ruby on Rails experiences serious security breach

A serious security vulnerability has forced the creators of Ruby on Rails to issue an immediate upgrade for the software. Version 1.1.5, which is being called a mandatory upgrade, is available now.

Rails 1.0 and prior, as well as 1.1.3, are not affected. The creators are still trying to determine how contaminated 1.1.0, 1.1.1, 1.1.2, and 1.1.4 are.

The vulnerability is so critical that the creators aren't disclosing any details so as to prevent attacks and protect people who are still in the process of upgrading.

From on the Riding Rails blog: "If you have a public Rails site, you MUST upgrade to Rails 1.1.5. The security issue is severe and you do not want to be caught unpatched."

Rails 1.1.5 is fully drop-in compatible with 1.1.4. It includes only a few bug fixes and no new features.

"As always, the trick is to do 'gem install rails' and then either changing config/environment.rb, if you're bound to gems, or do "rake rails:freeze:gems" if you're freezing gems in vendor," according to the advisory in the blog posting.

The creators are continuing their investigation into the breach and promise to issue a full report once it's complete and people have had enough time to upgrade.


posted on 2007-04-22 05:17 山风小子 阅读(515) 评论(0)  编辑  收藏 所属分类: Python & Ruby & RoROthers