Read Sean

Read me, read Sean.
posts - 508, comments - 655, trackbacks - 9, articles - 4

[Linux起步]配置Java和Eclipse环境

Posted on 2005-10-05 13:08 laogao 阅读(9631) 评论(7)  编辑  收藏 所属分类: On JavaOn EclipseOperating Systems

不知是不是因为Sun对Java发行版本的控制与GNU/Linux之间的矛盾加剧,很多Linux的发行版都不再默认附带Sun的JDK或JRE。举例来说,

1- 之前的SUSE Linux 9.2 Professional自带JDK 1.4.2,下载Eclipse后可以直接启动,而现在openSUSE Linux 10.0 RC1里面就找不到JDK的影子,默认的Repository里面也没有,需要自行安装。(也许归结于Professional版和openSUSE本身 产品定位的不同?)

2- 在Fedora Core 4的发行版中,附带的是GNU版的JRE,javac用的是Eclipse的版本,当然也附带了Eclipse,但那是基于Eclipse SDK 3.1M6加上CDT做成的native版本。虽然这些也能用,但是毕竟不是完整的Java,也不是原本的Eclipse。不信的话你可以下载一个最新的 Eclipse SDK 3.1.1,解压以后,根本不能正常启动界面。

由于我们一般能够获取的Linux发行版本都是免费的版本,而不是Professional或者Enterprise Server级别的,这些版本对Sun的JDK支持都很有限,另外Linux本身也鼓励我们去学一学如何DIY,我觉得有必要在完成了基本的Linux配 置后,自己安装JDK和Eclipse环境。

我们以使用比较广泛,也比较容易获取的Redhat Fedora Core 4 (http://fedora.redhat.com/)为例说明这个安装步骤。


<第一步>安装准备

我们这个时候可以打开一个命令行终端,输入"java -version",可以看到如下信息:

[sean@localhost ~]$ java -version
java version "1.4.2"
gij (GNU libgcj) version 4.0.0 20050519 (Red Hat 4.0.0-8)

Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

看到了吧?这并非Sun官方的Java。

我们需要到Sun的网站上下载最新的JDK,目前的版本是JDK 5.0 Update 5,注意,这里有两个版本:jdk-1_5_0_05-linux-i586-rpm.bin和jdk-1_5_0_05-linux- i586.bin,根据Fedora Core 4的Release Notes说明,应该使用后者,也就是不带rpm的版本。

同时,我们也需要到eclipse.org上下载最新的Eclipse SDK,目前版本3.1.1。需要根据你的系统环境选择合适的下载包,如:我的电脑是x86的,X Window系统用的是GNOME 2.10.0,那么自然应该选「x86/GTK 2」,文件名eclipse-SDK-3.1.1-linux-gtk.tar.gz。需要说明一下,FC4默认的X Window系统是GNOME,但是在KDE环境下,照样可以正常使用GTK的应用程序。


<第二步>安装和配置

我们现在打开一个命令行终端,输入命令su,提供root用户密码,进入管理员操作模式。然后用ls -l看一下刚刚下载的jdk-1_5_0_05-linux-i586.bin,可以看到它的权限是-rw-r--r--,所有者为sean。为了能够执 行它,需要更改它的权限设置。敲入命令chmod +x jdk-1_5_0_05-linux-i586.bin,再看权限,-rwxr-xr-x,可以执行了。

切换到/opt/目录,运行jdk-1_5_0_05-linux-i586.bin即可。注意:在Linux默认PATH不包含当前目录,即".",因 此执行当前目录的文件,正确的方法是在文件名前面加上"./"。成功以后可以发现在/opt/目录下多了一个jdk1.5.0_05子目录,这就是我们的 JAVA_HOME。

到这里还没完,在终端里检查java -version找到的仍然是原来的GNU版本,我们还需要配置系统的环境变量PATH。检查目前PATH内容的方式是echo $PATH,为了能够直接找到我们自己的java,需要把/opt/jdk1.5.0_05/bin目录加入PATH,并且要在GNU版本的前面,最保险 的办法当然是放到最前面了。方法是PATH="/opt/jdk1.5.0_05/bin:$PATH"。这之后再敲java -version,出来的就是正确的了:

[sean@localhost Java]$ java -version
java version "1.5.0_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot(TM) Client VM (build 1.5.0_05-b05, mixed mode, sharing)

为了今后登录的时候就把这个路径加到环境中,需要修改一下.bash_profile,先cd ~进入自己的主目录,然后用emacs或者vi编辑这个文件,找到PATH这一行,改成:
PATH=/opt/jdk1.5.0_05/bin:$PATH:$HOME/bin
保存,退出,注销然后重新登录。

接下来要做的就是把Eclipse解压到一个你认为合适的路径。


<第三步>开始使用

有很多方式运行我们的Eclipse:命令行或文件浏览器直接打开都可以。我这里告诉大家一个在GNOME里面比较方便的一种途径:从文件浏览器把eclipse运行文件拖放到系统的面板上,给它一个名字和图标,今后就可以直接点这个面板图标启动Eclipse了。

呵呵,总算看到熟悉的Eclipse界面,一种亲切感油然而生,不是吗?这个Eclipse已经自带Java开发环境,如果想做C/C++,Eclipse下面的CDT也很不错,当然了,以前N多插件也是照用不误,接下来怎么弄就看大家自己了。:)

Feedback

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2005-10-05 18:46 by tntht
问个问题撒
我安装和配置好后
java控制台不显示中文,甚至英文也没……
怎么解决?
我也是FC4的说

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2005-10-05 20:24 by 大胃
我这里也一样,但是我一般不去管那个ControlPanel,也就无所谓了,估计是FC4安装时设定默认语言为中文的关系。有空可以换回英文试试看。

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2005-10-06 09:50 by kukooBlog
安装了Sun JDK以后,关于路径的问题。 FC3/4下面,默认的GNU j,那个java应该是/usr/sbin下面的一个soft link。 因为我几乎不会用到这个GNU j,所以,可以把这个soft link删掉 (rm java),然后,重新创建一个 (ln -s /opt/jdk...../bin/java java)。 所以,我没有设置路径。 倒是JAVA_HOME还是要设置一下的为好。

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2005-10-06 12:06 by 大胃
To tntht:
我试过了, 在登录界面选择英文进入系统, ControlPanel可以正常显示. 在英文界面可以正常阅读中文, 只是默认不带中文输入法.

To kukoo:
呵呵, 谢谢提醒. 如此看来, 我的思维方式还不够UNIX. :P
还有, 正在想为何我的LumaQQ无法启动, 原来是少了JAVA_HOME. 顺便说说, 有些Java/SWT程序的启动脚本写得很好, 可以很智能的找到合适的JAVA_HOME而不会倚赖于我们自己的环境变量配置, 比如Azureus.

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2007-07-11 21:14 by bibi
各位大侠!怎么卸载linux下的jdk1.6

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2007-07-11 23:29 by 大胃
@bibi

删除jdk所在的目录。

# re: [Linux起步]配置Java和Eclipse环境  回复  更多评论   

2012-01-28 15:23 by Bill Zhao
http://sd.csdn.net/a/20111220/309393.html

只有注册用户登录后才能发表评论。


网站导航: