jinfeng_wang

G-G-S,D-D-U!

BlogJava 首页 新随笔 联系 聚合 管理
  400 Posts :: 0 Stories :: 296 Comments :: 0 Trackbacks
http://www.opensubscriber.com/message/axis-user@ws.apache.org/5260999.html

Now that I can get My hand written WSDL, I post this
reply as what to do, for all those having the same
problems.

1. Get the latest axis2 1.1 build (this works for the
   1-Nov-2006 nightly snapshot)

2. Structure of aar is to be as follows
    * MyService.aar
        /META-INF
            Services.xml
            service.wsdl
       /MyService.class

2. Naming 
    * The axis2 java code that looks for a deployed
      WSDL first looks for a wsdl named service.wsdl
      if it cannot find it it then looks for a wsdl
      named MyService.wsdl if that is not found a
      wsdl will be generated.

3. Ensure that Your names matchup in the WSDL and
   services.xml
    * In the wsdl The service name
      <wsdl:service name="MyService"> 'MUST' be
    * The same as the name in the services.xml
      <serviceGroup>
        <service name="MyService">
        ....
        </service>
      </serviceGroup>

4. Ensure that the
<parameter name="useOriginalwsdl">true</parameter>
   is set in the services.xml

<serviceGroup>
  <service name="MyService">
    <parameter name="useOriginalwsdl">true</parameter>
     ....
  </service>
</serviceGroup>



===========================
http://www.opensubscriber.com/message/axis-user@ws.apache.org/5247792.html


In my case it worked when I
put the parameter this way:

<parameter name="useOriginalwsdl">true</parameter>

And the structure of the .aar File is just like you described it at the
beginning:

AddressBook-v1-0-0.aar
   META-INF/AddressBook-v1-0-0.wsdl
   META-INF/services.xml
   au/...../some.class


posted on 2009-09-28 12:09 jinfeng_wang 阅读(3055) 评论(0)  编辑  收藏

只有注册用户登录后才能发表评论。


网站导航: