随笔-20  评论-78  文章-11  trackbacks-0
  2008年11月19日

载抄:
  1:VMware tools真是个好东西,,特别是98系统中,没了他系统就像老牛拉破车一样,哈哈,装了他一加速,马上好多了.
    将CD-ROM指向主机的虚拟光驱中,然后加载tools,一般默认的路径都是C:\program files\VMware\VMware Workstation\windows就可以了啊
   然后在客户机中打开我的电脑就可以看到了.(源自:http://www.xuniji.com/forum/view.asp?id=7597

  2:实现VMware虚拟机下安装Red Hat Linux后上网功能。
           参考网络资料:<<vmware 网络配置实例二 windows xp host + linux >>
 
  3:  在Linux操作系统下,与Windows分区显示方式不同,一般对应为:
           Windows                         Linux
             C:\                                 hda1
             D:\                                 hda5
             E:\                                 hda6
            .....
      hd表示IDE硬盘,a表示第一块硬盘(主盘),b表示第二块硬盘(从盘),c表示第一个光驱。后面的数字1,5,6分别表示第一个主分区(C:\),第一个扩展分区(D:\),第二个扩展分区(E:\)……注,Linux下1,2,3,4是预留给四个主分区的,不过通常,我们在Windows下只安排有一个主分区。
加载前需要在Linux系统的/mnt目录下新建几个子目录/mnt/winc、/mnt/wind、/mnt/wine……
  命令:mount -t vfat -o iocharset=cp936 /dev/hda1 /mnt/winc

  4:  vmnet1,vmnet0, vmnet8都是预设的网络接口,分别是指hostonly, bridge和nat. 他们几个同时存在,以适应不同的虚拟机的配置。例如,如果虚拟机的网络被设置成使用NAT,那么虚拟机内的eth0实际上是连接到vmnet8。
  使用NAT的方式我没有试验,不能多说什么,从资料上看,可能要要将vmnet8桥接到外网的网卡上,并且要修改一下注册表(因为默认的情况下vmware的网络接口不允许桥接,以防止它的dhcp包的泄漏)。

posted @ 2008-11-19 13:25 wahaha 阅读(184) | 评论 (0)编辑 收藏
  2008年11月14日
 1:vi的使用: i:在光标前插入字符。
                             a:在光标后插入字符。

 2:进入某一文件:cd
 3:在终端下使用vi操作/etc/inittab文件,可以修改登录方式。
 4:us命令
        功能说明:变更用户身份。
  语  法:su [-flmp][--help][--version][-][-c <指令>][-s ][用户帐号]
  补充说明:su可让用户暂时变更登入的身份。变更时须输入所要变更的用户帐号与密码
  参  数:
   -c<指令>或--command=<指令>  执行完指定的指令后,即恢复原来的身份。
   -f或--fast  适用于csh与tsch,使shell不用去读取启动文件
   -.-l或--login  改变身份时,也同时变更工作目录,以及HOME,SHELL,USER,LOGNAME。此外,也会变更PATH变量。
   -m,-p或--preserve-environment  变更身份时,不要变更环境变量。
   -s或--shell=  指定要执行的shell。
   --help  显示帮助。
   --version  显示版本信息。
   [用户帐号]  指定要变更的用户。若不指定此参数,则预设变更为root

         简单起见,它的用法还是贴了上来.进入正题:
       切换用户身份的两种情况: su username  和  su - username.下面就来说说它们的区别
假设现在以一般用户身份登陆系统,但此又想要查看一下系统网络配置信息,需要切换到root用户.
第一种情况:
            $ su root      切换到root用户,系统会提示输入口令,正确后切换成功
            $ ifconfig      查看网络配置信息
       但会发现,运行完 ifconfig命令后提示: bash: ifconfig: command not found
第二种情况:
            $ su - root      切换到root用户,系统会提示输入口令,正确后切换成功(比上面多了一条横线)
            $ ifconfig        查看网络配置信息
        这时就能达到用户真正的目的,查看到网络配置信息.

       这是为什么呢?我们都知道,有些命令是只有管理员才能使用的,一般用户没有权限.就像本例中的 ifconfig.用第二种方法切换身份,相当于重新登陆,此时用户的家目录和PATH等信息会发生改变,和直接用root登陆一致;但第一种情况,切换到root身份后用户的家目录和PATH仍然是原先一般用户的家目录和PATH,我们知道,PATH里设置的是一些路径,指向一些目录,这些目录包含着一些常用的工具.如果你的PATH没有设置相应的路径,那么直接运行ifconfig系统肯定会找不到ifconfig工具在哪里.所以会提示:没有这个命令.
       
5:Liunx下图形界面和文本模式的互相切换。
          在vmware中要使用:ctrl+alt+shift+f1可以实现从图形界面切换到文本模式。
           如果要回到图形界面,使用alt+F7就可以回到图形界面。
 1.开机进入文本模式

如果想让开机自动进纯文本模式,
修改/etc/inittab
找到其中的
id:5:initdefault:
这行指示启动时的运行级是5,也就是图形模式
改成3就是文本模式了
id:3:initdefault:

这是因为Linux操作系统有六种不同的运行级(run level),在不同的运行级下,系统有着不同的状态,这六种运行级分别为:
0:停机(记住不要把initdefault 设置为0,因为这样会使Linux无法启动 )
1:单用户模式,就像Win9X下的安全模式。
2:多用户,但是没有 NFS 。
3:完全多用户模式,标准的运行级。
4:一般不用,在一些特殊情况下可以用它来做一些事情。
5:X11,即进到 X-Window 系统。
6:重新启动 (记住不要把initdefault 设置为6,因为这样会使Linux不断地重新启动)。
其中运行级3就是我们要进入的标准Console字符界面模式。

2.强行退出X-Window进入文本模式

打开一个终端
输入init 3
(注意init后面有一个空格)
等一会就进入了图形界面

以上方法切换后,窗口模式完全关闭.如果窗口中有文件未保存,将丢失.
(用init 5可以回到图形界面,但原来的进程已死)

3.不退出X-Window进入文本模式

在X-Window图形操作界面中按"Alt+Ctrl+功能键Fn"(n=1~6),就可以进入文本模式界面。这就意味着你可以同时拥有X-Window加上6个文本模式界面,这是一件多么令人振奋的事情啊!

按“Alt+Ctrl+F7”即可从文本模式界面回到X-Window图形操作界面。这时Linux默认打开7个屏幕,编号为tty1~tty7。X-Window启动后,占用的是tty7号屏幕,tty1~tty6仍为字符界面屏幕。也就是说,用“Alt+Ctrl +Fn”组合键即可实现字符界面与X Window界面的快速切换。

当X-Window由于自身或应用程序而失去响应或崩溃时,我们可以非常方便地退出X-Window进入Console进行故障处理,要做的只是按“Alt+Ctrl+Backspace”键.






posted @ 2008-11-14 12:23 wahaha 阅读(217) | 评论 (0)编辑 收藏
  2008年10月28日
局域网就是将单独的微机或终端,利用网络相互连接起来,遵循一定的协议,进行信息交换,实现资源共享。网线常用的有:双绞线、同轴电缆、光纤等。双绞线可按其是否外加金属网丝套的屏蔽层而区分为屏蔽双绞线(STP)和非屏蔽双绞线(UTP)。从性价比和可维护性出发,大多数局域网使用非屏蔽双绞线(UTP-Unshielded Twisted pair) 作为布线的传输介质来组网。
UTP网线由一定长度的双绞线和RJ45水晶头组成
双绞线由8根不同颜色的线分成4对绞合在一起,成对扭绞的作用是尽可能减少电磁辐射与外部电磁干扰的影响。在EIA/TIA-568标准中,将双绞线按电气特性区分为:
三类、四类、五类线。网络中最常用的是三类线和五类线,目前已有六类以上的。
做好的网线要将RJ45水晶头接入网卡或HUB等网络设备的RJ45插座内。相应地RJ45插头座也区分为三类或五类电气特性。RJ45水晶头由金属片和塑料构成,制作网线所需要的RJ一45水晶接头前端有8个凹僧,简称“SE”(Position,位置)。
凹槽内的金属触点共有 8个,简称“8C”( Contact,触点),因此业界对此有“8P8C”的别称。特别需要注意的是RJ45水晶头引脚序号,当金属片面对我们的时候从左至右引脚序号是1~8,序号对于网络连线菲常重要,不能搞错。
EIA/TIA的布线标准中规定了两种双绞线的线序568A与568B。
568A标准:
绿白——1,绿——2,橙白——3,蓝——4,蓝白——5,橙——6,棕白——7,棕——8
568B标准:
橙白——1,橙——2,绿白——3,蓝——4,蓝白——5, 绿——6,棕白——7,棕——8
("橙白"是指浅橙色,或者白线上有橙色的色点或色条的线缆,绿白、棕白、蓝白亦同)。
双绞线的顺序与RJ45头的引脚序号要—一对应。
为了保持最佳的兼容性,普遍采用EIA/TIA 568B标准来制作网线。注意:在整个网络布线中应该只采用一种网线标准。如果标准不统一,几个人共同工作时准会乱套;更严重的是施工过程中一旦出现线缆差错,在成捆的线缆中是很难查找和剔除的。笔者强烈建议统一采用568B标准。
事实上10M以太网的网线只使用 1、2、3、6编号的芯线传递数据,即1、2用于发送,3、6用于接收,按颜色来说:橙白、橙两条用于发送;绿白、绿两条用于接收;4、5,7、8是双向线。
100M和1000M网卡需要使用四对线,即8根芯线全部用于传递数据。由于10M网卡能够使用按 100M方式制作的网线;而且双绞线又提供有四对线,所以日常生活中不再区分,10M网卡一般也按 100M方式制作网线。
另外,根据网线两端连接网络设备的不同,网线又分为直通线(平行线)和交叉线两种。直通线(平行线)就是按前面介绍的568A标准或568B标准制作的网线。而交叉线的线序在直通线的基础上做了一点改变:就是在线缆的一端把1和3对调,2和6对调。即交叉线的一端保持原样(直通线序)不变,在另一端把1和3对调,2和6对调。
交叉线两端的线序如下:
一端(不变) 另一端(对调两根)
橙白 1 3 绿白
橙 2 6 绿
绿白 3 1 橙白
蓝 4 4 蓝
蓝白 5 5 蓝白
绿 6 2 橙
棕白 7 7 棕白
棕 8 8 棕


直通线用于连接:
1.主机和switch/hub;
2.router和switch/hub

交叉线用于连接:
1.switch和switch;
2.主机和主机;
3.hub和hub;
4.hub和switch;
5.主机和router直连

在实践中,一般可以这么理解:
1、同种类型设备之间使用交叉线连接,不同类型设备之间使用直通线连接;
2、路由器和PC属于DTE类型设备,交换机和HUB属于DCE类型设备;
3、RJ45网络接头做法一般有568A和568B两种标准做法,按同一标准即直通线,不同标准即交叉线。
不管如何接线,最后完成后用RJ-45测线仪测试时,8个指示灯都应依次闪烁。
posted @ 2008-10-28 17:27 wahaha 阅读(996) | 评论 (0)编辑 收藏
  2008年9月2日

一 . 交换机和路由器
       交换机:我们经常说到的以太网交换机实际是一个基于网桥技术的多端口第二层网络设备,它为数据帧从一个端口到另一个任意端口转发提供了低时延、低开销的通路
       路由器:路由器是OSI协议模型的网络层中的分组交换设备(或网络层中继设备),路由器的基本功能是把数据(IP报文)传送到正确的网络,包括: 
     1.IP数据报的转发,包括数据报的寻径和传送; 
     2.子网隔离,抑制广播风暴; 
     3.维护路由表,并与其他路由器交换路由信息,这是IP报文转发的基础。 
     4.IP数据报的差错处理及简单的拥塞控制; 
     5.实现对IP数据报的过滤和记帐。 
 对于不同地规模的网络,路由器的作用的侧重点有所不同。 
在主干网上,路由器的主要作用是路由选择。主干网上的路由器,必须知道到达所有下层网络的路径。这需要维护庞大的路由表,并对连接状态的变化作出尽可能迅速的反应。路由器的故障将会导致严重的信息传输问题。
在地区网中,路由器的主要作用是网络连接和路由选择,即连接下层各个基层网络单位--园区网,同时负责下层网络之间的数据转发。
在园区网内部,路由器的主要作用是分隔子网。早期的互连网基层单位是局域网(LAN),其中所有主机处于同一逻辑网络中。随着网络规模的不断扩大,局域网演变成以高速主干和路由器连接的多个子网所组成的园区网。在其中,多个子网在逻辑上独立,而路由器就是唯一能够分隔它们的设备,它负责子网间的报文转发和广播隔离,在边界上的路由器则负责与上层网络的连接。

 二 . 二层交换机和路由器区别
     传统交换机从网桥发展而来,属于OSI第二层即数据链路层设备。它根据MAC地址寻址,通过站表选择路由,站表的建立和维护由交换机自动进行。路由器属于OSI第三层即网络层设备,它根据IP地址进行寻址,通过路由表路由协议产生。
     近几年,交换机为提高性能做了许多改进,其中最突出的改进是虚拟网络和三层交换。
     划分子网可以缩小广播域,减少广播风暴对网络的影响。路由器每一接口连接一个子网,广播报文不能经过路由器广播出去,连接在路由器不同接口的子网属于不同子网,子网范围由路由器物理划分。对交换机而言,每一个端口对应一个网段,由于子网由若干网段构成,通过对交换机端口的组合,可以逻辑划分子网。广播报文只能在子网内广播,不能扩散到别的子网内,通过合理划分逻辑子网,达到控制广播的目的。由于逻辑子网由交换机端口任意组合,没有物理上的相关性,因此称为虚拟子网,或叫虚拟网。虚拟网技术不用路由器就解决了广播报文的隔离问题,且虚拟网内网段与其物理位置无关,即相邻网段可以属于不同虚拟网,而相隔甚远的两个网段可能属于不同虚拟网,而相隔甚远的两个网段可能属于同一个虚拟网。不同虚拟网内的终端之间不能相互通信,增强了对网络内数据的访问控制。
 
三 .第三层交换机和路由器的区别 
  在第三层交换技术出现之前,几乎没有必要将路由功能器件和路由器区别开来,他们完全是相同的:提供路由功能正在路由器的工作,然而,现在第三层交换机完全能够执行传统路由器的大多数功能。作为网络互连的设备,第三层交换机具有以下特征:
1.转发基于第三层地址的业务流;
2.完全交换功能;
3.可以完成特殊服务,如报文过滤或认证;
4.执行或不执行路由处理。

第三层交换机与传统路由器相比有如下优点:
1.子网间传输带宽可任意分配:传统路由器每个接口连接一个子网,子网通过路由器进行传输的速率被接口的带宽所限制。而三层交换机则不同,它可以把多个端口定义成一个虚拟网,把多个端口组成的虚拟网作为虚拟网接口,该虚拟网内信息可通过组成虚拟网的端口送给三层交换机,由于端口数可任意指定,子网间传输带宽没有限制。
2.合理配置信息资源:由于访问子网内资源速率和访问全局网中资源速率没有区别,子网设置单独服务器的意义不大,通过在全局网中设置服务器群不仅节省费用,更可以合理配置信息资源。
3.降低成本:通常的网络设计用交换机构成子网,用路由器进行子网间互连。目前采用三层交换机进行网络设计,既可以进行任意虚拟子网划分,又可以通过交换机三层路由功能完成子网间通信,为此节省了价格昂贵的路由器。
4.交换机之间连接灵活:作为交换机,它们之间不允许存在回路,作为路由器,又可有多条通路来提高可靠性、平衡负载。三层交换机用生成树算法阻塞造成回路的端口,但进行路由选择时,依然把阻塞掉的通路作为可选路径参与路由选择。 

五 . 结论

综上所述,交换机一般用于LAN-WAN的连接,交换机归于网桥,是数据链路层的设备,有些交换机也可实现第三层的交换。路由器用于WAN-WAN之间的连接,可以解决异性网络之间转发分组,作用于网络层。他们只是从一条线路上接受输入分组,然后向另一条线路转发。这两条线路可能分属于不同的网络,并采用不同协议。相比较而言,路由器的功能较交换机要强大,但速度相对也慢,价格昂贵,第三层交换机既有交换机线速转发报文能力,又有路由器良好的控制功能,因此得以广播应用。

posted @ 2008-09-02 00:17 wahaha 阅读(5770) | 评论 (0)编辑 收藏
  2008年8月17日
[SW]int e1/0/2                                                                                     
[SW-Ethernet1/0/2]port link-type hybrid                                                        
[SW-Ethernet1/0/2]port hybrid vlan 1 2 * untagged                                                 
[SW-Ethernet1/0/2]port hybrid pvid vlan *                              
[SW-Ethernet1/0/2] save              
posted @ 2008-08-17 12:23 wahaha 阅读(151) | 评论 (0)编辑 收藏

刚刚看见比较好的命令介绍,与大家共享!!!

一、交换机简单管理协议增加指令----以便接入华为的管理软件
snmp-agent
snmp-agent community read public
snmp-agent community write private
snmp-agent sys-info version v1 v3
snmp-agent trap enable
备注:每台新增的交换机均需加入上述指令集合,否则不能为管理软件所管理

二、将新增交换机的VLAN1段设置IP地址
interface vlan 1
ip address 10.63.0.1 255.255.254.0


三、华为交换机指令的相关案例

[Quidway]super password                   修改特权用户密码
[Quidway]sysname                              交换机命名
[Quidway]interface ethernet 0/1            进入接口视图
[Quidway]interface vlan x                      进入X段VLAN接口视图
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0   为VLAN段设置地址
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2   静态路由=网关

[Quidway]user-interface vty 0 4
[S3026-ui-vty0-4]authentication-mode password
[S3026-ui-vty0-4]set authentication-mode password simple 222
[S3026-ui-vty0-4]user privilege level 3

[Quidway-Ethernet0/1]duplex {half|full|auto}         配置端口双工工作状态
[Quidway-Ethernet0/1]speed {10|100|auto}         配置端口工作速率
[Quidway-Ethernet0/1]flow-control               配置端口流控
[Quidway-Ethernet0/1]mdi {across|auto|normal}        配置端口MDI/MDIX状态平接或扭接
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 设置接口工作模式
[Quidway-Ethernet0/1]shutdown              关闭/重起接口
[Quidway-Ethernet0/2]quit                      退出系统视图

[Quidway]vlan 3                              创建/删除一个VLAN/进入VLAN模式
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4     在当前VLAN增加/删除以太网接口
[Quidway-Ethernet0/2]port access vlan 3              将当前接口加入到指定VLAN
[Quidway-Ethernet0/2]port trunk permit vlan {ID|All}       设trunk允许的VLAN
[Quidway-Ethernet0/2]port trunk pvid vlan 3      设置trunk端口的PVID

[Quidway]monitor-port <interface_type interface_num>         指定和清除镜像端口
[Quidway]port mirror <interface_type interface_num>        指定和清除被镜像端口
[Quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像

[Quidway]description string                          指定VLAN描述字符
[Quidway]description                            删除VLAN描述字符
[Quidway]display vlan [vlan_id]                      查看VLAN设置

[Quidway]stp {enable|disable}                        开启/关闭生成树,默认关闭
[Quidway]stp priority 4096                           设置交换机的优先级
[Quidway]stp root {primary|secondary}                设置交换机为根或根的备份
[Quidway-Ethernet0/1]stp cost 200                    设置交换机端口的花费

[SwitchA-vlanx]isolate-user-vlan enable              设置主vlan
[SwitchA]Isolate-user-vlan <x> secondary <list>      设置主vlan包括的子vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan <id>      设置vlan的pvid
[Quidway-Ethernet0/2]port hybrid pvid                删除vlan的pvid
[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged 设置无标识的vlan  
如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。
所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.
----------------------------------------
路由器命令
~~~~~~~~~~
[Quidway]display version                           显示版本信息
[Quidway]display current-configuration             显示当前配置
[Quidway]display interfaces                        显示接口信息
[Quidway]display ip route                          显示路由信息

[Quidway]sysname aabbcc                            更改主机名
[Quidway]super passwrod 123456                     设置口令  
[Quidway]interface serial0                         进入接口
[Quidway-serial0]ip address <ip><mask>
[Quidway-serial0]undo shutdown                     激活端口
[Quidway]link-protocol hdlc                        绑定hdlc协议
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode password
[Quidway-ui-vty0-4]set authentication-mode password simple 222
[Quidway-ui-vty0-4]user privilege level 3
[Quidway-ui-vty0-4]quit

[Quidway]debugging hdlc all serial0                显示所有信息
[Quidway]debugging hdlc event serial0              调试事件信息
[Quidway]debugging hdlc packet serial0             显示包的信息

静态路由:
[Quidway]ip route-static <ip><mask>{interface number|nexthop}[value][reject|blackhole]
例如:
[Quidway]ip route-static 129.1.0.0 16 10.0.0.2
[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]ip route-static 129.1.0.0 16 Serial 2
[Quidway]ip route-static 0.0.0.0 0.0.0.0   10.0.0.2


动态路由:
[Quidway]rip
[Quidway]rip work
[Quidway]rip input
[Quidway]rip output
[Quidway-rip]network 1.0.0.0                        ;可以all
[Quidway-rip]network 2.0.0.0
[Quidway-rip]peer ip-address
[Quidway-rip]summary
[Quidway]rip version 1
[Quidway]rip version 2 multicast
[Quidway-Ethernet0]rip split-horizon              ;水平分隔

[Quidway]router id A.B.C.D                        配置路由器的ID
[Quidway]ospf enable                              启动OSPF协议
[Quidway-ospf]import-route direct                 引入直联路由
[Quidway-Serial0]ospf enable area <area_id>       配置OSPF区域


标准访问列表命令格式如下:
acl <acl-number> [match-order config|auto]        默认前者顺序匹配。
rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]
例:
[Quidway]acl 10
[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255
[Quidway-acl-10]rule normal deny source any


扩展访问控制列表配置命令

配置TCP/UDP协议的扩展访问列表:
rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}
[operate]

配置ICMP协议的扩展访问列表:
rule {normal|special}{permit|deny}icmp source {<ip wild>|any]destination {<ip wild>|any]
[icmp-code] [logging]

扩展访问控制列表操作符的含义
equal portnumber        等于
greater-than portnumber        大于
less-than portnumber        小于
not-equal portnumber        不等
range portnumber1 portnumber2 区间

扩展访问控制列表举例
[Quidway]acl 101
[Quidway-acl-101]rule deny souce any destination any
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply

[Quidway]acl 102
[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0
[Quidway-acl-102]rule deny ip source any destination any

[Quidway]acl 103
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www


[Quidway]firewall enable
[Quidway]firewall default permit|deny
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound


地址转换配置举例
[Quidway]firewall enable
[Quidway]firewall default permit
[Quidway]acl 101
[Quidway-acl-101]rule deny ip source any destination any
[Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any
[Quidway]acl 102
[Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0
[Quidway-acl-102]rule permit tcp source any destination 202.38.160.1 0 destination-port great-than
1024

[Quidway-Ethernet0]firewall packet-filter 101 inbound
[Quidway-Serial0]firewall packet-filter 102 inbound

[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1
[Quidway]acl 1
[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255
[Quidway-acl-1]rule deny source any
[Quidway-acl-1]int serial 0
[Quidway-Serial0]nat outbound 1 address-group pool1

[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp


PPP验证:
主验方:pap|chap
[Quidway]local-user u2 password {simple|cipher} aaa
[Quidway]interface serial 0
[Quidway-serial0]ppp authentication-mode {pap|chap}
[Quidway-serial0]ppp chap user u1         //pap时,不用此句

pap被验方:
[Quidway]interface serial 0
[Quidway-serial0]ppp pap local-user u2 password {simple|cipher} aaa

chap被验方:
[Quidway]interface serial 0
[Quidway-serial0]ppp chap user u1        
[Quidway-serial0]local-user u2 password {simple|cipher} aaa

posted @ 2008-08-17 12:19 wahaha 阅读(274) | 评论 (0)编辑 收藏
  2008年8月7日
  1.  软件开发模型(Software Development Model):①瀑布模型(Waterfall Model)渐增/演化/迭代(incremental model)③原型模型(prototype model)螺旋模型(spiral model)喷泉模型(fountain model)智能模型(intelligent model) 7. 混合模型(hybrid model).
  2. OOD: (Object-Oriented Design )方法是OO(object-oriented)方法中一个中间过渡环节。其主要作用是对OOA(object-oriented analysis)分析的结果作进一步的规范化整理,以便能够被OOP(object-oriented programming)直接接受。
  3. 封装:(encapsulation)把内部实现的细节隐藏起来,外部无法访问,仅提供某些功能。继承:子类具有父类的功能。多态:在不同的上下文条件下有不同意义或用法的功能。重载:在一个类有多个同名的方方法,但在操作数个数或类型上有区别。消息:向对象发送的服务请求。对象用消息的方式传递信息,而不是参数。
  4. css选择器:类型选择器、id选择器、派生选择器、群选择器、通配选择器、伪类和伪对象选择器。
  5. application和session的区别: application是全局变量,面向应用。session是私有变量,面向连接。
  6. (1)接口可以被多重implements,抽象类只能被单一extends
    (2)接口只有定义,抽象类可以有定义和实现
    (3)接口的字段定义默认为:public static final, 抽象类字段默认是"friendly"
  7. 什么是Web容器?
    实现J2EE规范中web协议的应用.该协议定义了web程序的运行时环境,包括:并发性,安全性,生命周期管理等等.
  8. 解释下面关于J2EE的名词
    (1)JNDI:Java Naming & Directory Interface,JAVA命名目录服务.主要提供的功能是:提供一个目录系统,让其它各地的应用程序在其上面留下自己的索引,从而满足快速查找和定位分布式应用程序的功能.
    (2)JMS:Java Message Service,JAVA消息服务.主要实现各个应用程序之间的通讯.包括点对点和广播.
    (3)JTA:Java Transaction API,JAVA事务服务.提供各种分布式事务服务.应用程序只需调用其提供的接口即可.
    (4)JAF: Java Action FrameWork,JAVA安全认证框架.提供一些安全控制方面的框架.让开发者通过各种部署和自定义实现自己的个性安全控制策略.
    (5)RMI:Remote Method Interface,远程方法调用

posted @ 2008-08-07 01:43 wahaha 阅读(280) | 评论 (0)编辑 收藏
  2008年8月5日
1 dhcpdiscover: 此为client开始DHCP过程中的第一个请求报文.
2 dhcpoffer   :  此为server 对dhcpdiscover 报文的响应.
3 dhcprequst  : 此为client 对dihcpoffer 报文的响应.
4 dhcpdeclient: 当client发现server 分配给它的IP地址无法使用,如IP地址发生冲突时,将发出此报文让server禁止使用这次分配的IP地址。
5 dhcpack     : server对 dhcprequst 报文的响应,client收到此报文后才真正获得了IP地址和相关配置信息.
6 dhcpnak     : 此报文是server对client的dhcprequst报文的拒绝响应,client 收到此报文后,一般会重新开始DHCP过程.
7 dhcprelease :此报文是 client主动释放IP地址,当server 收到此报文后就可以收回IP地址分配给其他的client.


posted @ 2008-08-05 01:32 wahaha 阅读(246) | 评论 (0)编辑 收藏
  2008年8月1日
每一种工作在一家公司都不是无故存在的,都会有它的作用存在。通常在面试中,都会被问到,QA在公司产品研发中的作用是什么,当然我也会常常问求职者这样的问题。那QA的作用到底是什么呢?不是一个非常重要就能概括的,今天这篇短文,总结一下,我认为的QA的作用,纯属个人观点,希望大家共同讨论。因为我做的是家用消费类电子产品,所以就以这种产品为例,写一下我的观点。
    一家公司看准了一个产品市场,准备去做研发了,那么,市场部的人员会做市场调查,看看用户对于这种产品的需求是什么。这时候QA就要介入进来,共同reivew这份需求,我给这份需求书起个名字‘MKR’。研发部门会根据MKR来制定公司的产品规格书。从制定公司产品的spec开始,QA就需要介入了。QA需要站在终端用户的角度来考量这份spec所定义的东西是否符合用户的使用习惯,是否符合行业标准,是否与业内通行的默认的潜规则一致,等等。如果QA认为有任何的错误,都应该及时向研发部门提出异议,这样才能从最初期保证产品的质量。要知道产品的致命缺陷通常都是因为设计理论本身就有问题,导致后端开发人员无法弥补,而最终产生严重后果。在这点上,QA需要积极地与PM合作,推动研发部门改正不合理的设计方案。做为家用消费类产品,我们要以终端用户的使用习惯为最终的要求。
    在spec制定出来以后,QA就要投入到紧张的工作当中。在研发人员开发的同时,QA需要制定出test plan和test case。
    QA如何制定test plan呢?
    这项工作需要与项目经理和design team的人使用共同完成。首先,我们需要从PM那里得到project schedule,根据schedule来制定QA的test plan。test plan包括产品测试的具体内容,release schedule,release test plan and schedule, code management,QA的工作流程和参与人员的工作安排与职责。
    test case是一个非常详细的工作,我就不在这说明了,这需要经验,根本也不是三言两语可以说得清楚的,但可以介绍一下大的方向。写test case的宗旨是让测试变得最简单,看case的人哪怕完全不懂,是个新手,也能按照case去完成测试的工作,并且给出测试结果;尽量减少人为的经验因素带来的影响,将需要测试的方面,和有可能被忽略的方面都要写进去,让case成为一个众人经验的集合,达到case的最大功效。
    当然test plan制定以后不是一直不变的,需要大家一同来review,而减少QA本来有可能带来的失误,因为是人都会有想不到的,有犯错误的时候。这个就需要QA与PM和design team的人去沟通,需要大大小小很多的review meeting来解决。这个时候千万不要怕麻烦,这个时候偷了懒,危机就在后面等着你。这时候会遇到很多困难,design team的人通常很难合作,因为对于那些研发工程师来说,这种meeting是非常讨厌的,肯定会排斥。但就是被排斥,得不到合作,也不可以放弃,QA应该坚持自己的原则,这里就会考验到一个人的沟通能力了。
    上面的工作都做完了,QA会得到小小的休息时间。按步就班的做事,开始跟着PM和研发进度走。到了产品研发成熟期,客户会出现,这时候,QA又会起到重要的作用。在这里提一下,有些健全的大公司,把QA分成了两个team。与研发部门合作,只做产品研发测试的development QA,与客户打交道,接受客户投诉,帮客户产品质量把关的customer QA,我们公司在发展的后期,就出现了CQA和DQA。如果说公司QA分成这两部分,那么QA的工作就变成更为复杂。
    DQA的使命只是维护研发期的产品质量,我们把这种产品叫reference design products,而CQA的使命是维护客户的产品质量。
    不管是在产品的研发中,还是在客户产品的质量维护中,QA还有一个重要的职责,就是推动力,QA要成为工程师们工作的推手。人都有惰性,不要期望每个人都自觉地努力工作。QA的通常做法是,每周给出一个进度报告,做一次bug review。通常研发部门的工程师非常讨厌这种会议,那没办法,我给大家一个小方法。QA把每目前严重的问题分列出来,详细到把每个负责的工程师所属的bug全部列出来,告诉工程师们这些bug需要被fixed时间,然后群发email,当然不要忘记CC给老大们喔,这样才够power。当然,态度不可以太强硬,最好在邮件结尾加一句,如果有困难,可以提出,meeting中商量。通常都会有人接受meeting。一个研发工程师手中通常不会只有一种产品,那么就会有冲突的时候。QA需要问清楚优先级和工程师的难处,尽量解决,这样才能达到良好的协调。协调好了,工作效率会更高。不过,有些公司,把这类工作交由PM来做,但本人认为,推动公司的产品质量朝更好的方向发展,是QA义不容辞的责任。
    整理这些也不容易,我目前只想到这么多了,以后想到再补充吧。下次我会详细给大家介绍QA的工作流程
posted @ 2008-08-01 16:33 wahaha 阅读(2255) | 评论 (0)编辑 收藏
  2008年7月10日
     摘要:   Java学习之路:不走弯路,就是捷径 在ChinaITLAB导师制辅导中,笔者发现问得最多的问题莫过于"如何学习编程?Java该如何学习?"。类似的问题回答多了,难免会感觉厌烦,就萌生了写下本文的想法。到时候再有人问起类似的问题,我可以告诉他(她),请你去看看《Java学习之路》。拜读过台湾蔡学镛先生的《Java夜未眠》,有些文章如《Java学习之道》等让我们确实有共鸣,本文题目也...  阅读全文
posted @ 2008-07-10 16:32 wahaha 阅读(435) | 评论 (3)编辑 收藏
仅列出标题  下一页