Sky's blog

我和我追逐的梦

常用链接

统计

其他链接

友情链接

最新评论

m2eclipse 0.9.7安装问题

从http://m2eclipse.sonatype.org/update下在线安装m2eclipse,现在的版本是0.9.7,20090209的版本,应该是新出来的。安装时出现错误提示导致无法安装:

Cannot complete the request.  See the details.
Cannot find a solution satisfying the following requirements org.eclipse.ui.workbench [3.4.2.M20090127-1700].

这个错误比较古怪,我用的是最新的eclipse 3.4.2 jee的版本,特地跑eclipse目录plugins下去看,发现有org.eclipse.ui.workbench_3.4.2.M20090127-1700.jar
和上面要求的版本完全一致啊,怎么就报错了呢?

google了一圈,完全没有收获,似乎大家都没有遇到类似问题?

逐个尝试,发现有三个东西和这个org.eclipse.ui.workbench_3.4.2.M20090127-1700有依赖:
maven scm handler for subclipse
maven integration for ajdt
maven integration for wtp
在google上搜到一篇文章:
M2eclipse在Eclipse3.4.1下的详细安装步骤
http://blog.csdn.net/zhaosen241/archive/2008/10/22/3122779.aspx
提到要先安装Web Tools Platform (WTP),但是我测试过发现还是没有解决问题。我用link方式安装了最新版本的Web Tools Platform (WTP) ,再次安装m2eclipse 0.9.7时还是报上面同样的错误。

最后没辙了,放弃上面的三个造成错误的东东,安装其他内容,一路顺利安装,m2eclipse可以正常运行。

始终还是不明白为什么会报org.eclipse.ui.workbench_3.4.2.M20090127-1700的错误??哪位可以赐教?

posted on 2009-03-18 06:40 sky ao 阅读(2658) 评论(8)  编辑  收藏 所属分类: project building

评论

# re: m2eclipse 0.9.7安装问题 2009-03-18 11:43 唧唧歪歪

I think it's a bug at all!  回复  更多评论   

# re: m2eclipse 0.9.7安装问题 2009-03-18 12:57 何啟宁

没遇到这样的问题,  回复  更多评论   

# re: m2eclipse 0.9.7安装问题 2009-03-25 17:34 s.well

确实要先装AJDT先  回复  更多评论   

# re: m2eclipse 0.9.7安装问题 2009-04-27 21:41 julysea

兄弟,我也遇到这个问题了。不过解决了,说起来简单,就是不完全安装就是了。
我是去掉了ajdt、subversion相关的选项,就可以安装了  回复  更多评论   

# re: m2eclipse 0.9.7安装问题 2009-05-21 15:26 subeclipse

我也遇到这个问题,头都大了~~~  回复  更多评论   

# re: m2eclipse 0.9.7安装问题[未登录] 2009-10-28 17:18 菜鸟

我现在也遇到这个问题了。。。头痛呀。。  回复  更多评论   

# re: m2eclipse 0.9.7安装问题[未登录] 2009-10-28 17:19 菜鸟

哪位大哥如果看到小弟的求救,麻烦联系我.QQ:297057283 邮箱:lxsoftware.engineer@gmail.com  回复  更多评论   

# re: m2eclipse 0.9.7安装问题 2009-10-30 10:30 sky ao

"放弃上面的三个造成错误的东东"

帖子里面不是很清晰的说明了解(或者说是 避开)这个问题的方法吗?有没有试过?  回复  更多评论   


只有注册用户登录后才能发表评论。


网站导航: