Sky's blog

我和我追逐的梦

常用链接

统计

其他链接

友情链接

最新评论

在eclipse 3.4 Ganymede 中安装subclipse和subversive

   首先说一下这几天折腾eclipse 3.4和subclipse的臭事,极其郁闷,浪费不少时间。
  
   简单的说,就是eclipse3.4和subclipse插件的问题。我的工作用机有两个,公司的笔记本和家里的台式机。事情的过程是这样:

   1. 家里的机器升级到eclipse 3.4,用links方式安装原来给3.3版本用的subclipse,一起正常,可以使用

   2. 几天后想着试试在公司笔记本上安装eclipse 3.4,用links方式安装原来给3.3版本用的subclipse,无法使用。反复试了很多次,都不行,其他插件links可以正常安装,比如testng,lockness之类。

   3. 搞不懂公司机器到底是什么毛病,因为家里机器是ok的,因此怀疑是不是公司下的eclipse 3.4有问题。从家里copy eclipse 3.4的安装文件到公司。解压,links安装,subclipse1.4.3正常安装可以使用。

   4. 本来事情到这里按说就结束了,但是,回家后,由于其他原因我将eclipse 3.4 删除了,准备重新安装。结果发现同样的问题发生了,死活都安装不上去subclipse,我试过1.4.3,1.2.6,1.0.6都不行。和上次公司笔记本上的情况一模一样!

   5. 在公司打开笔记本,打开eclipse 3.4,发现subclipse1.4.3一切正常,简直......

   今天本着“老子不信邪”的想法,恩,我感觉自己都有些偏执了,最后仔细研究了一把,终于将问题搞清了一些。感觉eclipse 3.4 Ganymede的插件安装机制相对有了很多变化,比如多了一个dropin方式,管理器也变化了很多,尤其特别喜欢下载。link方式安装时好时坏的问题可能和这个有关,具体原因不去深究了,只能在出问题的时候想办法避开了。
  
   还有eclipse 3.4 Ganymede可以考虑用subversive替代subclipse了,尤其是subversion 1.5的支持,如果有需要用到subversion 1.5。
  
   最后总结一下eclipse 3.4 Ganymede插件的安装方式,link方式就不说了,大家自己看运气吧。

1. 使用管理器安装subclipse 1.4.3
    可以使用http://subclipse.tigris.org/update_1.4.x 在线安装,可以正常安装和使用。
    试过用管理器直接指向本地已经下载好的zip文件,也可以同样安装,但是安装过程中还是会去下载一些小的文件,新版本的管理器太
    依赖网络了。
   
2. 使用管理器安装subversive

    具体的安装方法可以参考这里: http://www.eclipse.org/subversive/downloads.php
    简单的说,主要是两个Update Site:
    1. subversive:
        http://download.eclipse.org/technology/subversive/0.7/update-site/
    2. connector:
        http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/
        推荐使用svnkit,而且注意从上面地址下载的svnkit对subversive有版本要求,而eclipse 3.4 Ganymede自带的升级站点上的
        subversive版本不够,所以会无法安装。请注意http://www.eclipse.org/subversive/downloads.php里面的说明。
       
    唠叨一下,整个过程挺无聊的,我只是想简单连个subversion而已,搞的这么复杂,有点反感eclipse 3.4 Ganymede新版本了,要不是有几个新特性是我比较喜欢的都想放弃升级到3.4了。
   

posted on 2008-08-30 19:16 sky ao 阅读(7170) 评论(9)  编辑  收藏 所属分类: Version Control

评论

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2008-08-30 23:07 xcliu

根据我的经验,使用link方式在3.4下安装还是可以的,但是一定要分成多个link, 先安装不依赖其他插件的插件,再安装有依赖性的插件;也有可能有一些插件会造成其他插件使用link方式安装失败,要先安装;总之,我使用的插件经过反复试,现在只要使用特定的顺序安装,用link方式总算可以方便的安装了。

另外,我使用subversive有半年了,我觉得还是 "Native JavaHL" 比较稳定 (windows xp环境下),使用svn kit发生过几次总是提交失败的情况(都有目录的重命名/移动/删除的操作,部分操作是在 explorer中操作的,而不是在eclipse中操作的),但是使用 "Native JavaHL"就可以正确提交,再取出来也是正确的。
  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2008-08-31 00:27 提示

我在eclipse3.4下使用subclipse 1.4.3 插件,没什么问题啊!
  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2008-08-31 22:22 Matthew Chen

link方式和dropin不是差不多的方式吗?还以为插件丢进dropin里面就是了,只是免除写link这个步骤而已...  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2008-09-29 23:32 ps

同感,我安装 rdt和dltk也是同样的问题,到现在都还没搞好,头都大了  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2008-10-02 17:55 koven

我估计问题应该出在你没有清空一下workspace里的残留设置  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2009-04-10 15:50 zkj8421

以前看这篇文章多次,似乎解决;但却好像没病根;
今天再看到:“感觉eclipse 3.4 Ganymede的插件安装机制相对有了很多变化,比如多了一个dropin方式,管理器也变化了很多,尤其特别喜欢下载”;恍然大悟,如果联网不成功就失败,会不会就插件安装不成?于是把site.xml 删掉,eclipse-clean, 马上找到插件了;
不知道这是否是真正的原因,困扰我好多个月的问题就这么解决了?。。。
呵呵,待证明,至少这一次是立竿见影。

  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2009-04-10 17:44 sky ao

删掉site.xml,看到很多类似的问题最后都会以这个方式解决,难道eclipse的这些莫名其妙的问题都是这个造成的?

不管怎样,以后再遇到类似的事情,通通清空,eclispe重装,workspace删除......实在烦了这些鬼事了。  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2009-04-18 06:34 Daniel Hu

我也整理了一些Eclipse中Svn插件的安装配置文档,还加上了一些快捷方式设置的内容
http://hi.baidu.com/dearhwj/blog/item/31598034550a4046251f1434.html  回复  更多评论   

# re: 在eclipse 3.4 Ganymede 中安装subclipse和subversive 2013-03-20 16:20 田长军

我也遇到过这个问题,头都大了,最后丢到dropins下,OK了。  回复  更多评论   


只有注册用户登录后才能发表评论。


网站导航: