svn: This client is too old to work with working copy.. 

Posted on 2009-05-20 13:42 林光炎 阅读(7252) 评论(0)  编辑  收藏 所属分类: SVN
svn: This client is too old to work with working copy ; 由于svn工作拷贝目录下都有个.svn目录,里面保存着svn需要的一些版本信息等,当客户端软件升级后,里面的信息也相应增加以支持更多的特性。比如如果你在终端下用1.4版本的svn客户端co了一份代码,然后到windows下用tortoiseSVN去操作,会在.svn里增加一些文件。那么以后你再想回到1.4版本去工作,就会有兼容性错误,因为老的客户端(如:subclipse 1.0.6)无法识别那些,所以会报错:"svn: This client is too old to work with working copy '.'; please get a newer Subversion client".

用下面这个脚本就可以解决了,来自tortoiseSVN官网: http://www.blogjava.net/Files/lingy/change-svn-wc-format.rar  用法如:

python change-svn-wc-format.py ./projctName "1.4" --verbose


附件:在文件中。。。。。


还好我在windows下装了 python ,顶python ~

posts - 104, comments - 33, trackbacks - 0, articles - 0

Copyright © 林光炎