冷面阎罗

低调做人&&高调做事
随笔 - 208, 文章 - 3, 评论 - 593, 引用 - 0
数据加载中……

jdk版本的问题

        大家发布web程序,出现如下这样的错误么?我只知道是jdk的版本问题,我机器上安装了4 5 6三个版本的jdk,应该是jdk6和jdk5冲突造成的。
        我解决过一次,就是把所有的jdk全删除,然后安装我使用的jdk的版本,问题就没有了,不过这样解决不是最佳方法。
        不知道大家有么有别的好的解决方法?


posted on 2008-01-11 13:33 冷面阎罗 阅读(630) 评论(3)  编辑  收藏 所属分类: java

评论

# re: jdk版本的问题[未登录]  回复  更多评论   

只装6就可以了,或者装5,现在用5的应该是最多的,不过6用的开始也多了。
2008-01-12 04:32 | say

# re: jdk版本的问题  回复  更多评论   

看你的服务器支持那个版本,然后以那个版本的JDK来编译就行了,
我平时是用eclipse, 设置preferences / java / compiler ,在右边的窗口里设
compiler compliance level 为 5.0.
2008-01-12 18:31 | javadragon

# re: jdk版本的问题  回复  更多评论   

其实我不想装那么多
每个项目都不同,weblogic8只能用jdk4
其个人是只想装6,不过我们还有的项目用3的jdk
2008-01-14 09:30 | 冷面阎罗

只有注册用户登录后才能发表评论。


网站导航: