posts - 168,  comments - 30,  trackbacks - 0

2012-01-08 18:14:40     我来说两句 
收藏
以前从来没有使用过ruby,这两天刚好要使用GitHub上的离线wiki系统gollum,所以要在偶的ubuntu下安装ruby和ruby-gems。其中遇到一些问题:
 
 
 
如果使用apt-get install ruby 和apt-get install rubygems1.8
 
当使用gem install 命令时报以下错误:
 
 
 
ERROR: While executing gem ... (TypeError) instance of Date needs to have method `marshal_load
 
 
 
可能是Ubuntu环境的原因,那么就改用rvm安装,参考了http://beginrescueend.com/rvm/install/
 
若以非root模式安装:
 
 
 
bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer )
 
 
 
 
 添加rvm scripts路径变量到bash:
 
 
 
     echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # Load RVM function' >> ~/.bash_profile
 
  
 
 让新的bash生效:
 
 
 
     source ~/.bash_profile
 
 
 
安装ruby1.9.2:
 
    rvm install 1.9.2
 
 
 
让系统默认使用1.92:
 
    rvm use 1.9.2 --default
 
 
 
 
 
 
检查安装是否OK:
 
    ruby  -v
 
--------------------------------------------
 
接下来安装rubygems
 
先到官网下载安装包http://rubygems.org/pages/download
 
 
 
 
然后安装
 
ruby setup.rb
 
 
 
 
默认采用淘宝的Gem镜像站点
 
 
 
 
gem source http://ruby.taobao.org/
 
 
 
 
接下来就可以使用gem install xxx命令了,just enjoy it!
 
 
 
 
PS:如过使用gem install报错,可能是Ubuntu本身少一些依赖,比如我安装gollum时缺少依赖libxml2,libxslt,
 
缺少啥就install 啥:
 
 
 
apt-get install libxml2
 
apt-get install libxslt
 
转自:
http://www.2cto.com/os/201201/116337.html
posted on 2012-03-14 10:08 David1228 阅读(832) 评论(0)  编辑  收藏 所属分类: Linux云计算、虚拟化

只有注册用户登录后才能发表评论。


网站导航:
 

<2012年3月>
26272829123
45678910
11121314151617
18192021222324
25262728293031
1234567

常用链接

留言簿(3)

随笔分类

随笔档案

文章档案

新闻分类

新闻档案

相册

收藏夹

Java

Linux知识相关

Spring相关

云计算/Linux/虚拟化技术/

友情博客

多线程并发编程

开源技术

持久层技术相关

搜索

  •  

积分与排名

  • 积分 - 310170
  • 排名 - 161

最新评论

阅读排行榜

评论排行榜