WindowBuilder Pro (SWT/Swing/GWT Designer) v6.40 Released

     

  Window BuilderPro是一款基于Eclipse SWT技术上的双向Java Gui设计软件。具备SWT设计、Swing设计以及GWT设计功能。该软件会被作为一个插件镶嵌入Eclipse以及其他一些兼容的IDEs中。

    
    WindowBuilder is a new family of professional GUI building products for Java. WindowBuilder products seamlessly integrate into Eclipse based IDEs and provides exceptionally powerful and intuitive tools for creating rich client Java applications.   It includes SWT Designer, Swing and GWT Designer. 

    Major new WindowBuilder v6.4.0 release includes SWT/JFace Data Binding support,GWT 1.4.10 support, icon decorators, plus many other new features.

* SWT/JFace Data Binding support
- Support SWT Data bindings
- Support JFace Data bindings
- Icon decorator for bound components
- Data Binding menu
- Property pane support for "binding" property
- Create Data Binding wizard
- Choose Bean targets, models and inputs
- Choose Widget targets and models
- Choose selection targets, models and inputs
- Choose collection inputs
- Filter targest and models
- Filter properties
- Specify SWT binding properties
- Specify JFace binding properties
- Edit and Delete existing bindings
- Generate initDataBindings() method
* Enhanced GWT support
- Improved support for OSX
- Support for GWT 1.4.10
- Support for ImageBundle from 1.4.10
- Support for new GWT 1.4.10 widgets
- Use Label as placeholder for bad widgets
- Support for alignment of widgets in cells of Grid and FlexTable
* Enhanced SWT support
- Support for drop action from ActionFactory in tree
- Support for drop action to MenuManager, ToolBar on CoolBar in tree    
* Enhanced JFace & RCP Support
- Support for "delete" action for ActionInfo
* Enhanced Swing Support
- Support for JGoodies forms 1.1.0
* Enhanced NLS support
- Support for source containers from plugin fragments
* Editor & Property Pane enhancements
- optional decoration of components with events
- Remember last selection and expansion state on refresh
- Work around preventing preview window flickering on Metacity

System Requirements

WindowBuilder/SWT Designer/Swing Designer Requirements

* Windows 98/ME/NT/2000/XP/Vista or Linux+GTK2
* OSX (requires Eclipse 3.3 & JDK 1.5 Release 5 Developer Preview 2)
* Any Eclipse 2.1, 3.0, 3.1, 3.2 or 3.3 based IDE
- Eclipse SDK 2.1.x, 3.0.x, 3.1.x, 3.2.x or 3.3 (JDK 1.4 or higher)
- Rational Application Developer 7.0.x
- Rational Application Developer 6.0.x
- WebSphere Studio Application Developer (WSAD) 5.1.x
- WebSphere Studio Site Developer (WSSD) 5.1.x
- WebSphere Studio Enterprise Developer (WSED) 5.1.x
- Etc.

GWT Designer Requirements

* Windows NT/2000/XP/Vista or Linux+GTK2
* [Beta] Mac OSX (see OSX Installation instructions)
* GWT 1.2.22 or higher from http://code.google.com/webtoolkit/download.html
* Any Eclipse 3.2 or 3.3 based IDE
- Eclipse SDK 3.2.x or 3.3
- Rational Application Developer 7.0.x
- Etc.

官网:http://www.instantiations.com/windowbuilderpro/default.htm

Full Installer for Windows (47M) for Eclipse 2.1, 3.0, 3.1, 3.2 & 3.3:
http://downloads.instantiations.com/WBPro/continuous/latest/WBPro_v6.4.0_win32_x86.exe
Full Installer for Linux (48M) for Eclipse 2.1, 3.0, 3.1, 3.2 & 3.3:
http://downloads.instantiations.com/WBPro/continuous/latest/WBPro_v6.4.0_linux_x86.bin
Zip Edition for Eclipse 3.3 (27M) For Windows, Linux, or OSX:
http://downloads.instantiations.com/WBPro/continuous/latest/WBPro_v6.4.0_for_Eclipse3.3.zip
Zip Edition for Eclipse 3.2 (27M) For Windows, Linux, or OSX:  
http://downloads.instantiations.com/WBPro/continuous/latest/WBPro_v6.4.0_for_Eclipse3.2.zip
官方更多下载:http://www.instantiations.com/windowbuilderpro/download.html


      

posted on 2007-07-01 00:01 XiaoLi 阅读(7848) 评论(0)  编辑  收藏 所属分类: EclipseOthers


只有注册用户登录后才能发表评论。


网站导航:
 

公告


文章发布许可

本站作品均采用知识共享署名-非
商业性使用-禁止演绎 2.5 中国大
陆许可协议
进行许可。

Books I've Translated

《精通Nginx(第二版)》

精通Nginx(第二版)
《云计算:原理与范式》

 云计算:原理与范式

《SQL技术手册(第三版)》
SQL技术手册(第三版)
《MySQL核心技术手册(第二版)》
MySQL核心技术手册(第2版)
《RESTful Web Services中文版》
RESTful Web Services中文版

51.la 专业、免费、强健的访问统计

导航

留言簿(2)

随笔分类

搜索

最新评论