不可不说
随心所欲,无往不利!
posts - 88,  comments - 92,  trackbacks - 0
飞鸽传书是大家经常使用的局域网通讯工具,网上找了很多方法都不能正确使用,经过多次实验
终于找到正确的方法,特此说明:
1:下载最新的飞鸽传书代码 目前为止是0.9.6 GNOME2版本
   原版下载页:http://www.ipmsg.org/index.html.en
   修改版下载:
   http://www.blogjava.net/Files/bukebushuo/g2ipmsg_0.9.6.tar.gz
   这个是我修改后的源码再打包后文件,主要改了三个文件:
   codeset.c (去掉了一些字符编码)
   codeset.h (修改了默认字符编码)
   README    (修改了执行命令)
2:从终端进入解压后的目录执行一下命令:
   2.1) ./configure --prefix=/usr --sysconfdir=/etc --enable-systray  --with-ext-charcode=GBK
        注意:执行这个命令主要是查看有无关联库未安装,根据提示用apt-get进行安装
大多情况下会显示如下信息(部分):
...
No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'glib-2.0' found
...
这时我们可以执行如下命令:
sudo apt-get install libgnomeui*
提示是否安装时,输入Y即可
WARNING: You need GStreamer-0.10 or later installed if you need ...
上面警告可以执行:
sudo apt-get install gstreamer*-dev
安装结束再来一次检查,反复进行,直到不再出现No package提示信息为止。
   2.2) sudo make
   2.3) sudo make install
3: 我编译完后,飞鸽传书出现在菜单 应用程序->附件中
4:从菜单点击执行或者终端执行/usr/bin/g2ipmsg即可出现在托盘中
5:进入飞鸽,从菜单 设置->首选项中设置 字符编码的外部代号为GBK。
OK,结束!


posted on 2009-04-19 11:46 蓝剑 阅读(3634) 评论(5)  编辑  收藏 所属分类: Linux

FeedBack:
# re: Ubuntu 8.10 编译安装飞鸽(IPMsg 0.9.6)
2009-04-20 08:31 | 大道自然
用你的方式没有安装成功啊。
这是执行出现下面信息
./configure --prefix=/usr --sysconfdir=/etc --enable-systray --with-ext-charcode=GBK

checking for doxygen... no
configure: WARNING: doxygen not found - will not generate any doxygen documentation
checking for perl... /usr/bin/perl
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for intltool >= 0.31... 0.37.1 found
checking for xgettext... no
checking for msgmerge... no
checking for msgfmt... no
configure: error: GNU gettext tools not found; required for intltool
  回复  更多评论
  
# re: Ubuntu 8.10 编译安装飞鸽(IPMsg 0.9.6)
2009-04-20 21:40 | 蓝剑
楼上的,需要安装gettext
sudo apt-get install gettext  回复  更多评论
  
# re: Ubuntu 8.10 编译安装飞鸽(IPMsg 0.9.6)
2010-03-24 16:38 | xiedejian
ronnie@ronnie-desktop:~/下载/g2ipmsg$ ./configure --prefix=/usr --sysconfdir=/et
c --enable-systray --with-ext-charcode=GBK
checking for doxygen... no
configure: WARNING: doxygen not found - will not generate any doxygen documentation
checking for perl... /usr/bin/perl
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for intltool >= 0.31... 0.37.1 found
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for dirfd... yes
checking for asctime_r... yes
checking for localtime_r... yes
checking for pkg-config... /usr/bin/pkg-config
checking OpenSSL options with pkg-config... no
checking for gdi32... no
checking for CRYPTO_lock in -lcrypto... no
checking for CRYPTO_add_lock in -lcrypto... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for G2IPMSG... yes
checking for DBUSGLIB... no
checking whether to be enable dbus-glib... no
checking whether to be enable gnome-screensaver-interaction... nodbus-glib not available
checking for SYSTRAY... yes
checking whether to be enable systray... yes
checking whether to be enable IPMSG UTF-8 extension support... no
checking whether to be enable applet... yes
checking for APPLET... configure: error: Package requirements (libpanelapplet-2.0) were not met:

No package 'libpanelapplet-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables APPLET_CFLAGS
and APPLET_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


这样子应该怎么做啊~~~

我在网上找了好多方法都不行啊``也下了好几种版本  回复  更多评论
  
# re: Ubuntu 8.10 编译安装飞鸽(IPMsg 0.9.6)
2010-03-24 18:02 | xiedejian
@xiedejian
这个问题已搞定,但完成后在附件也有IPMSG,就是无法运行怎么回事啊`  回复  更多评论
  
# re: Ubuntu 8.10 编译安装飞鸽(IPMsg 0.9.6)
2010-03-24 18:18 | xiedejian
@xiedejian
已搞定``  回复  更多评论
  

只有注册用户登录后才能发表评论。


网站导航:
 


<2009年4月>
2930311234
567891011
12131415161718
19202122232425
262728293012
3456789

常用链接

留言簿(6)

随笔分类(62)

随笔档案(90)

文章档案(9)

相册

友情链接

搜索

  •  

积分与排名

  • 积分 - 304808
  • 排名 - 162

最新评论

阅读排行榜

评论排行榜