blog.Toby

  BlogJava :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  130 随笔 :: 2 文章 :: 150 评论 :: 0 Trackbacks
在使用visual studio.net过程中,已经有几次遇到“visual studio.net已检测到指定的web服务器运行的不是asp.net1.1版。无法运行asp.net web应用程序 ”这样的问题,很是恼火,害得我重新安装。NET多次,经过一再研究,找到解决这个问题的根本办法:

1.你的Web服务器使用了固定IP:确定你的“Internet信息服务”中使用的是“默认web站点”并且其属性中的IP地址为“(全部未分配)”,而不是你己指定的ip地址。然后在回到VS.NET中重试,或许可以解决。 
2.以上方法不能解决问题时,考虑MSDN中的解决办法,如下: 
Visual Studio .NET 无法确定在 Web 服务器计算机上运行的是否为 ASP.NET 1.1 版。该错误可能在几种不同情况下发生。请检查是否属于以下情况: 
• 确保 .NET Framework 1.1 版安装在 Web 服务器计算机上。有关详细信息,请参见 Visual Studio .NET 软件要求。 
• 如果 ASP.NET 已安装在 Web 服务器计算机上,但仍然遇到此错误,则可能是配置问题。为了纠正有问题的安装或配置,可以使用名为 aspnet_regiis 的 ASP.NET 实用工具。在类似如下所示的路径中可以找到此命令行实用工具: 
C:\WINDOWS\Microsoft.NET\Framework\v1.1.nnnn\ 
其中 nnnn 表示四位内部版本号。在最高版本号下查找。使用 /i 开关运行该实用工具: 
aspnet_regiis /i 
提示   您可以从命令的正确目录中直接打开该命令窗口。从 Windows 的“开始”菜单,指向“程序”、“Visual Studio .NET 2003”、“Visual Studio .NET 工具”,然后选择“Visual Studio .NET 命令提示”。在窗口打开后,键入 aspnet_regiis /i。
posted on 2006-07-25 09:33 渠上月 阅读(244) 评论(0)  编辑  收藏 所属分类: other tips

只有注册用户登录后才能发表评论。


网站导航: