zhyiwww
用平实的笔,记录编程路上的点点滴滴………
posts - 536,comments - 394,trackbacks - 0

我在本地编译和调试好的程序一点问题也没有,但是,当我上传到远程服务器的 Tomcat 上一测试就抛异常,我一直也不知道是什么原因。上网搜了一下,知道了症结所在。

问题所在:

      因为,我们在本地使用的编译器和服务器上使用的编译器版本不同所致。

     我在本地上编译使用的 JDk 版本是 jdk5.0, 而远程服务器上的 jdk 的版本是 jdk1.4, 所以我编译的程序在远程就出错。

解决办法:

(转载自 http://paperman.blog.hexun.com/2125191_d.html

      1 .Jbuilder2006 自带了1.5JDK,但如果你还想 继续用JDK1.42,如果只是在Jbuilder2006
tool->configure->JDKs中添加一个JDK1.42或更低版 本,那么即使你只写一个最简单的HelloWorld程序,Jbuilder2006都会给你报出长长一串错误,编写的代码在Jbuilder2005中也无法运行。
JBuilder2006在运行编译工程时,会针对特定版本的VM进行编译,默认的是Java 2 SDK, v 5.0 And Late,因此,如果工程用的是1.5以下的JDK,碰到都是java.lang.UnsupportedClassVersionError这个错误。

解决的办法其实很简单,只要更改这个选项就行了。具体步骤如下:
----------------------------------------------------------
1
、右键点击工程文件,选择属性(properties),
2
、在属性窗口中选择 Build-->Java,在右边的选项中有四个下拉框,就可以看到编译选项了,
3
、其中CompilerDebug Option可以不用管,只在Languege featuresTarget VM中选择相应的JDK版本就可以了,然后确定,一切OK
附件中是配置的图片。
-----------------------------------------------------------
如果在Target VM中选择了All Java SDKs,那么你的class文件在使用JDK1.1VM上都可以运行(Jbuilder2006帮助中是这么说的,估计没几个人的机子上还在用JDK1.1 :-

2.Eclipse3.1 同样会出现相同的问题,这时候只需要把项目用的JDK与你安装的JDK搞成版本一样就解决了.

步骤:右击你的项目-->属性-->Java Compiler,设置合适的版本!!



|----------------------------------------------------------------------------------------|
                           版权声明  版权所有 @zhyiwww
            引用请注明来源 http://www.blogjava.net/zhyiwww   
|----------------------------------------------------------------------------------------|
posted on 2007-01-16 16:32 zhyiwww 阅读(131038) 评论(5)  编辑  收藏 所属分类: j2ee

FeedBack:
# re: java.lang.UnsupportedClassVersionError问题的解决方法
2008-11-24 10:10 | yes
windows->preferences->java->compiler
改为1.5或1.6,看你自己的需求,多试两次
compiler setting changed->yes  回复  更多评论
  
# re: java.lang.UnsupportedClassVersionError问题的解决方法
2009-10-12 09:55 | xuyutom
不错,谢谢!  回复  更多评论
  
# re: java.lang.UnsupportedClassVersionError问题的解决方法
2010-01-05 16:55 | mugua
太感谢了   回复  更多评论
  
# re: java.lang.UnsupportedClassVersionError问题的解决方法
2010-01-05 17:03 | mugua
害我弄了2小时 老在下jdk和配环境变量  回复  更多评论
  
# re: java.lang.UnsupportedClassVersionError问题的解决方法
2012-03-18 13:43 | Mr.wu
非常感谢. 还以为项目的 build path里面设置了 jdk1.6的就可以,
原来跟compiler有关系  回复  更多评论
  

只有注册用户登录后才能发表评论。


网站导航: