OSGI的依赖关系真郁闷

它不说, 你稀里糊涂 导致服务没启动.......

org.eclipse.equinox.ds_1.2.0.v20100507 需要依赖 org.eclipse.osgi.util_3.2.100.v20100503

搞了半天, 才发现啊....

以至于Declarative Service不成功.

当然Eclipse比较好,他可以自动帮你查找需要依赖的bundle, Intellij Idea没这功能.......

posted on 2010-07-16 15:20 Scud(飞云小侠) 阅读(212) 评论(0)  编辑  收藏 所属分类: OSGI


只有注册用户登录后才能发表评论。


网站导航:
 
<2010年7月>
27282930123
45678910
11121314151617
18192021222324
25262728293031
1234567

导航

统计

公告

文章发布许可
创造共用协议:署名,非商业,保持一致

我的邮件
cnscud # gmail


常用链接

留言簿(14)

随笔分类(113)

随笔档案(103)

相册

友情链接

技术网站

搜索

积分与排名

最新评论

阅读排行榜

评论排行榜