庄周梦蝶

生活、程序、未来
   :: 首页 ::  ::  :: 聚合  :: 管理

紧急发布xmemcached 1.3.5

Posted on 2011-10-01 15:11 dennis 阅读(3975) 评论(6)  编辑  收藏 所属分类: javamy open-source

    xmemcached紧急发布1.3.5版本,主要是修复两个相对严重的bug:

Issue 154: 在重连本地memcached的时候,有可能出现重连无法成功的情况,导致连接丢失,详情见这里
Issue 155: 重连导致文件句柄数超过限制的bug,这是由于重连失败情况下没有合理关闭socket引起的,详情见这里

    如果你使用maven,简单升级版本即可:
 <dependency>
      
<groupId>com.googlecode.xmemcached</groupId>
      
<artifactId>xmemcached</artifactId>
      
<version>1.3.5</version>
 
</dependency>


    下载地址:http://code.google.com/p/xmemcached/downloads/list

    此版本推荐升级,最后感谢两位老外开发者的帮助: ilkinulasMrRubato

评论

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-10-06 22:54 by open-lib
能否提交一个encoder是基于hession实现的?

如果自己实现,是否基于Transcoder这个接口实现的?

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-10-06 23:07 by dennis
@open-lib
是的,然后通过setTranscoder设置进去即可。
官方不准备提供,你可以自己实现。

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-10-07 17:35 by open-lib
@dennis
按照你的经验,哪个效率高啊?

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-10-12 17:12 by flyby
xmemcached将来能否持osgi呀,现在必须要手动改变jar的meta-inf文件才行

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-11-30 15:23 by hyzw
1.3.5不支持遍历KEY了吗 ,KeyIterator 废弃了 用什么方法遍历呢?

# re: 紧急发布xmemcached 1.3.5  回复  更多评论   

2011-11-30 15:32 by dennis
@hyzw
仍然支持的,但是已经不建议使用。因为memcached 1.4开始不支持这个协议了。

只有注册用户登录后才能发表评论。


网站导航: