何以解忧?唯有Java

其实程序员也懂得浪漫!
posts - 90, comments - 637, trackbacks - 0, articles - 2
  BlogJava :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理

netbeans 6.5 多国语言 开发版发布了!

Posted on 2008-09-24 15:15 guanminglin@gmail.com 阅读(24968) 评论(35)  编辑  收藏 所属分类: NetBeans
这个不是最终版,想尝鲜的朋友可以到官方 网站上下载了!



http://bits.netbeans.org/download/trunk/nightly/latest/ml/?pagelang=zh_CN

NetBeans 6.5 带来很多新的特性,大家可以尝试一下,说不定 你就会喜欢上他的。呵呵!

下面是NetBeans 6.5 中新增的特性以及 增强的功能 一览表:

http://wiki.netbeans.org/NewAndNoteWorthyMilestone1NB65

http://wiki.netbeans.org/NewAndNoteWorthyMilestone2NB65



评论

# re: netbeans 6.5 多国语言 开发版发布了![未登录]  回复  更多评论   

2008-09-24 16:26 by 颜小诗
如果原来安装啦 Netbeans 英文版的 能不能直接更新升级为中文版呢?!

如果可以应该如何操作哦

邮件教导下吧 Email:qingxianyan@gmail.com

谢谢咯

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-09-24 22:34 by IceRao
谢谢了。一直使用英文版的开发版。现在已经非常不错了。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-06 15:33 by MD
贱人!
居然支持没用的PHP,却不支持PYTHON
另外:支持STRUTS2不?
还有,你这BLOG不能显示图片,和NETBEANS一样贱!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-06 16:39 by 日月雨林@gmail.com
@MD
现在的人怎么这样阿? 动不动就骂,骂的很开心吗?
如果你不喜欢,你可以不用Netbeans ,没人强求你用。不要动不动就骂人。
netbeans 既然支持php 就有它自己的道理,他的市场不仅仅只有中国。
netbeans 怎么会不支持python 呢? 你自己到java.net 上找吧。
还有Struts2 的支持早就有了,你自己到官方的网站上找。
我的博客里也有介绍过。

最后我的博客不能显示图片,是应为我把图片的文件名给改了,忘了更新了。
就算不能看,你也没必要骂人吧,我又没欠你的。netbeans 也没欠你的。

望你多积点口德!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-08 13:02 by JSF
@日月雨林@gmail.com
对,netbeans就是犯贱!好好的python不支持,却支持恶心的php,就是找骂的。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-08 13:53 by 日月雨林@gmail.com
@JSF
NetBeans 不支持Python 吗? 你真的很无知!

[url]]https://nbpython.dev.java.net/[/url]

还有Struts2 也支持:
[url]https://nbstruts2support.dev.java.net/ [/url]

无知并不可怕,但是你现在还不知道自己无知,那就不好办了!

你到下面的地址上找吧 有很多工具的。
http://community.java.net/projects/community/javatools


望你多积点口德!要不然会有报应的。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-09 10:44 by JSF
@日月雨林@gmail.com

兄弟,可以通过其它插件支持PYTHON,这哪个不知道?
问题是Netbeans没有内置地支持PYTHON,如果没有内置的支持,它的稳定性、后续升级维护、功能是否完善都很难得到保障。
就好比你说的对struts2的支持,我不知道6.5有没有支持,但我知道6.1是不支持的,也是需要另装插件才支持,明白没?
如果说要通过另装插件才能支持,那可以说Netbeans可以支持任何语言。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-09 13:52 by 日月雨林@gmail.com
@JSF
你如果认为第3方的插件,不行,那么我无话可说了。
python 的支持估计会晚一点,就像groovy 一样。

如果思所有的东西都内置支持的话,连eclipse 我看都不行的。
况且eclipse 支持的语言还没有netbeans 多。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-09 14:30 by JSF
@日月雨林@gmail.com

别的我不敢说,但就对PYTHON的支持上来讲,eclipse做得比Netbeans好(因为Netbeans根本就没有做嘛),Eclipse有官方提供的对Python和Jython支持的插件。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-09 15:54 by 日月雨林@gmail.com
@JSF
那你也可以到netbeans 的官方插件中心看看有没有Struts2的支持。Python
很快也会在官方dailybuilder 里了,Python和Jython 的插件现在是由两名Python和Jython的开发人员,进行开发的。
还有ecipse 官方插件里有提供的插件多半是第三方的插件更本不是官方自己的。
前面你还说要内置支持,现在又把第三方的插件拿出来讲,有意思吗?

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-10 09:56 by 日月雨林
@JSF
你可以到这个网站上看看,NetBeans是不是对python 进行了
内置支持 http://deadlock.netbeans.org/hudson/

这里是Continuous Integration Builds for NetBeans Projects
他的意思不用我和你说了吧!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-10 10:33 by JSF
我正用着呢,还用你说?
内置与第三方本身就不存在矛盾。
如果内置(或官方认可,即官方指定或推荐在这个环境上使用此插件),就有了一定的保障性。
但在Netbeans上,针对Python一直没有这种。Netbeans中可用的针对Python的插件不只一种,那么做为开发人员,当然是期望使用官方开发或推荐的成熟的产品。
为什么要拿Python来说事?
先不拿Python与PHP语言本身来比较,就说Jyphon(Python)与JAVA走得如此之近,却没得到支持,但PHP与JAVA屁的关系都没有,反倒这么快就得到了支持,这怎么也让人感觉别扭吧?

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-10 10:52 by 日月雨林@gmail.com
@JSF
用着呢,还说没有内置支持?无语!
至于php的支持,那是Sun 对市场的分析把握,NetBeans的市场并不是只有中国
Python的支持只是稍微的晚点,并不是没有支持,为什么要说没有支持呢?

你说Jyphon(Python)与java走得近,却没得到支持,那groovy 与ruby 的支持你应该看到了吧,只是时间上的一点差异而已,况且NetBeans 已经在开发Python的插件了。还有NetBeans支持的语言更多的是该语言方面的专家在进行开发,开发的快慢并不是NetBeans所能控制的。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-10 17:05 by JSF
@日月雨林@gmail.com

是啊,连RUBY这种语言都那么早就提供了支持,而PYTHON的支持不是只“稍微晚点”而已,而是到现在都没有官方推荐的正式版本。
Netbeans与Eclipse的区别在于:Netbeans有强大的SUN做后盾,这也是部分开发人员选择Netbeans的原因之一。Netbeans的开发与维护没有很强地依赖于第三方或自由开发人员。一个语言或功能是否在Netbeans中得到了支持及支持的好坏,反映了Netbeans团队对在Netbeans中提供该语言或功能的重视层度。
另外:无论到哪个国家,PHP这种败落的、只能开发几个小型公司网站的语言都不会有太大的用武之地。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-11 13:26 by 肉鸟
神的定律:
骂人的都是菜鸟

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-11 21:07 by 日月雨林@gmail.com
@JSF
Sun 不是笨蛋,市场需求他比你清楚。
netbeans 的语言支持,并不完全是netbeans 团队所能够完成的,他靠的是社区的力量。如果你也有能力,你就不要在这里怨天尤人了,赶快开发一个超过目前版本的Python插件吧。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-13 11:18 by JSF
@日月雨林@gmail.com

非常搞笑的逻辑。
照你这种说法,你还是继续喝三鹿吧,
如果你也有能力,你也可以自己开个牛奶厂,超过三鹿。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-13 13:14 by 日月雨林@gmail.com
@JSF
逻辑是你没有弄清楚吧,我喝过三鹿吗?我要求过三鹿什么吗?我看搞笑的人是你~!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-13 13:16 by 日月雨林@gmail.com
@肉鸟
支持你!!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-13 17:08 by JSF
@日月雨林@gmail.com

说你钻牛角尖,你还别不信。
很明显我的意思是说:照你那种说法,你对任何事情都不用开口说话了。买了质量有问题的东西,你也别开口,谁叫你自己不开个加工厂呢?买了本烂书,你也别开口,谁叫你自己不写一本呢?你也别说什么Netbeans的6.5比5.5好用,有本事你自己开发一个比5.5好用的呀?
想起很多书托们经常用的一句话:你说这本书写得不好,有本事你自己写一本呀

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-13 18:50 by 日月雨林@gmail.com
@JSF
说到钻牛角尖,你比我厉害多了,而且你偷换概念的能力也是没的说的。
开始的时候是说netbeans 不支持Python ,自己又在用着netbeans官方的python 插件。现在又说插件的质量问题。无语!

还有,你现在用的免费的工具,没人强制你用,也没人收你的钱,你如果不满意可以去提交bug ,或者你可以用其他的工具。这个和花钱买书是两回事。
我承认我可没那个能力去开发netbeans。但是我理解它,开发IDE 是件困难的事。
我能够作的是提交我发现的bug,和对netbeans 的改进意见。并不是去说他这个不好,那个不好。到时候又去用人家的东西。


# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-19 11:02 by O。O
所谓的开源就是大家都可以做 , 和三鹿可以比的么 ?
netbeans就是大家都可以做插件,有能力的话就可以自己动手,如果没时间就等别人动手 。
三鹿可以么 ?
说道netbeans,一直在关注,但仍在用eclipse,因为项目用这个做的。

还有嫌货才是买货人,说书不好往往是买书的人,因为需要所以挑剔。如果自己能写书,要买书干吗 ?

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-19 11:34 by 日月雨林@gmail.com
@O。O
说的有道理!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-19 17:18 by 猎人
吵什么啊,一群白痴, sun已经发布 支持python 插件的 6.5 测试版啊,
坐井观天,一群井底之蛙

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-10-30 09:37 by 。。。
@JSF
你真是个人才呀,那句话怎么说来着,I服了U

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-05 00:16 by 路人
路过,看见争执得厉害......
@日月雨林:你应该是正常的。
@JSF:你有点问题,是否最近代码写多了,自己都绕糊涂了?你这状态不论用什么开发工具写出来的代码,都没人敢要的。一个好的程序员,首先应该搞清楚的是你需要完成什么工作,面对怎样的环境,你的精力应该用在如何达成目标上面,而不是去抱怨需求或者环境有问题,进而错乱自己的逻辑。至于一个开发工具,它的成熟总是要有一个过程,就像你自己的代码也需要渐渐完善一样。都是搞开发的,便应该知道写个大东西不是容易的事情,多一些宽容与鼓励,给一些实质的帮助,你便有可能更快地获得你想得到的特性。不为而怒,不但见识短,且损人不利己,长此以往,崩溃的不会是别人。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-07 18:00 by phper
PYTHON 在我们中国用的人很多吗??支不支持无所谓吧

哈哈,,支持 php ,,好

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-08 09:23 by 日月雨林@gmail.com
@路人
谢谢你的理解!
@phper
既然netbeans 选择支持她就有她自己的道理。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-08 13:45 by
JSF,就是一个SB,鉴定完毕

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-11 10:30 by 我日哦
不就tmd一个IDE么?至于吵成这样么?

# re: netbeans 6.5 多国语言 开发版发布了![未登录]  回复  更多评论   

2008-11-11 10:47 by bird
前面那个骂人的菜鸟,你们没看出来吗?为了搬出几个专业术语,提醒大家注意所以~~~~~~~~,唉

# re: netbeans 6.5 多国语言 开发版发布了![未登录]  回复  更多评论   

2008-11-22 14:32 by ty
我也是等待netbeans的python插件很久了,又一次失望中。。。
看来还得继续用eclipse

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-22 20:32 by 日月雨林@gmail.com
@ty
netbeans for python EA 已经发布了!

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2008-11-28 15:37 by 泥巴麒麟
那些破玩艺根本就不要支持,就支持java就行了。其实我就觉得那个精简版挺好的,给我个ant跑就全搞定了。

# re: netbeans 6.5 多国语言 开发版发布了!  回复  更多评论   

2009-04-01 00:54 by 瓦砾哇啦
JSF,我本来想学编程的,看到你的话,我突然觉得编程可能会让人不正常。我怕我找不到老婆,所以我打算不学编程了。谢谢你让我没有被毒害成你这样。

只有注册用户登录后才能发表评论。


网站导航: