随笔-167  评论-65  文章-0  trackbacks-0

环境:ubuntu 8.10 en version

安装ror版本 : ruby 1.8.7 + rails 2.1.0


1,安装ruby


sudo apt-get ruby

安装结束后 可以用ruby -v 查看安装结果

feng@feng:~$ ruby -v


ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]



2,安装rubygems

sudo apt-get rubygems

安装结束后可以用 gem -v 查看安装结果

feng@feng:~$ gem -v


1.3.4



3,安装完rubygems后可能不是最新版,需要更新一下,更新的方法

$ sudo gem install rubygems-update

4,安装rails

sudo gem install -v=2.1.0 rails

安装结束后,可以用 rails -v 查看下安装结果

feng@feng:~$ rails -v


Rails 2.1.0



刚开始我用的是sudo gem install rails,安装的是最新版,但是和ruby1.8.7不协调,最后又卸了rails,重新装了rails 2.1.0,卸载方式如下:

gem list 列出所有gem包,


feng@feng:~$ gem list




*** LOCAL GEMS ***




actionmailer (2.1.0)


actionpack (2.1.0)


activerecord (2.1.0)


activeresource (2.1.0)


activesupport (2.1.0)


calendar_date_select (1.15)


rails (2.1.0)


rake (0.8.7)


rmagick (2.9.2)



然后逐一删除

sudo gem uninstall rails



sudo gem uninstall actionmailer

ref

http://hi.baidu.com/pepsichan/blog/item/dc1e030a58c9021795ca6bde.html


http://hi.baidu.com/pepsichan/blog/item/8cf53dec6957432f62d09f1c.html






write by feng
posted on 2009-06-24 18:18 fl1429 阅读(226) 评论(0)  编辑  收藏 所属分类: Rails

只有注册用户登录后才能发表评论。


网站导航:
 
已访问数:
free counters