如何搭建j2ee开发环境--面向初学者

本文主要是为开源项目simplejee写的,但基本还是通用的。

开发java程序最低的要求是有jdk和文本编辑器。不过多数来说我们都会使用一些辅助的文本编辑器(editplus,UltraEdit)甚至集成开发环境(IDE),如eclipse,IntelliJ IDEA等,我们放在代码库里的代码并没有限定开发工具,也没有将和开发工具相关的配置文件提交到代码库里,但为了方便在downloads下放了两个带有eclipse配置信息的zip包。

java和j2ee运行环境搭建

jdk

这类资料网上很多。

  • 首先到sun公司网站下载jdk安装程序,http://java.sun.com/javase/downloads/index.jsp
  • 运行该程序,一堆同意和接受
  • 配置环境变量,只需要配置JAVA_HOME和path就可以了。JAVA_HOME是你安装jdk的根目录,如C:\Program Files\Java\jdk1.6.0_06,path是已经存在的一个环境变量,在开头添加%JAVA_HOME%\bin;就可以了。

tomcat 的安装

为了能够运行jsp,servlet等程序,我们需要一个servlet容器,使用最广,资料最多的应该就是tomcat了。
直接到tomcat的网站下载,然后解压就可以使用了。 http://tomcat.apache.org/download-60.cgi ,这个是tomcat6.x的版本的网址,找到Binary Distributions,Core,下面有个zip,点击该链接下载。
解压tomcat后,到其bin目录下点击startup.bat就可以启动tomcat了,然后访问 http://localhost:8080 就可以看到那只著名的大猫了。
另外tomcat还有exe的安装版,不推荐使用。

开发工具

eclipse的安装

直接到eclipse的官方网站下载( http://www.eclipse.org/downloads/ )。选择javaee的版本(Eclipse IDE for Java EE Developers)。
eclipse无需安装解压即用。当然你最好整个快捷方式在桌面上。

eclipse的svn插件subclipse

首先了解一下版本管理和subversion 的概念。然后在网上搜索subclipse,有很多相关资料,图文并茂,我就不再赘言了。但因为这些文章都是针对稍旧版本的eclipse,在最新的eclipse下初学者可能会有点困惑,所以我就写了一个简单的介绍 http://code.google.com/p/simplejee/wiki/subclipse

ant和maven

这也是java开发中采用的工具,ant本身已经集成在eclipse里了,maven也有eclipse插件。
对于ant你要了解build.xml的编写,在simplejee根目录下有个简单的build.xml可以先参考一下,然后在菜单栏里Window > Show View > Ant,打开ant的view,就可以看到类似下图的界面,

然后,点击带加号的蚂蚁图标,将你项目下的build.xml加入进来。 参考文章http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.user/gettingStarted/qs-85a_ant_view.htm
http://www.ibm.com/developerworks/cn/java/j-lo-ant-eclipse/index.html,
至于maven,可参考 http://code.google.com/p/simplejee/wiki/maven

其他

数据库

因为我们的重点是基于数据库的软件开发,所以你需要安装一个数据库软件,推荐mysql。我的T42跑oracle比较吃力。安装mysql的话,可以直接下载一个mysql,再找个mysql的管理软件。另外如果你还做php开发,或有兴趣学php的话,可以尝试安装个xampp ,也蛮好的。

编辑器

另外eclipse这类IDE比较大,启动比较慢,所以常常开发人员都还安装一些小巧的编辑器,比较著名的应该是editplus和UltraEdit,后者功能更强大些,但收费,而前者更小巧,如果你不交钱的,只是每次启动多点一下“I Agree”,所以我推荐使用editplus

网页调试工具

firefox的firebug是你今后调试网页和javascript的好帮手。另外firefox插件Live HTTP Headers, ie插件 ieHTTPHeaders有时也需要。另外在ie里目前只有ie8可以正确的指出javascript错误的具体行数,如果错误发生在引入的js文件里,ie8之前的版本不能正确提示。另外ie8提供了一个开发人员工具,在工具菜单下,支持断点调试等。

posted on 2010-02-20 11:59 一农 阅读(2680) 评论(0)  编辑  收藏


只有注册用户登录后才能发表评论。


网站导航:
 

公告

南京 java辅导班 约等于免费 详见yuqiaotech.com

导航

<2010年2月>
31123456
78910111213
14151617181920
21222324252627
28123456
78910111213

统计

常用链接

留言簿(10)

随笔档案

文章分类

文章档案

相册

搜索

最新评论

阅读排行榜

评论排行榜