小导的博客

成功的人不是赢在起点,而是赢在转折点,机会是献给有准备的人。

手把手构建Maven企业级应用(整合SSI框架)《3》

下面我们进行SSI整合到Maven构建的程序之中,首先你需要选定你需要整合的版本,因为Maven依赖关系是需要指定Version的,下面是我整合所需要的SSI版本(我用Maven的依赖关系表示):

 1 <!--Spring-->  
2 <dependency>
3 <groupId>org.springframework</groupId>
4 <artifactId>spring</artifactId>
5 <version>2.5.6</version>
6 </dependency>
7 <!--Ibatis-->
8 <dependency>
9 <groupId>org.apache.ibatis</groupId>
10 <artifactId>ibatis-sqlmap</artifactId>
11 <version>2.3.4.726</version>
12 </dependency>
13 <!--Struts2-->
14 <dependency>
15 <groupId>org.apache.struts</groupId>
16 <artifactId>struts2-core</artifactId>
17 <version>2.1.8.1</version>
18 </dependency>

当然有的新手可能会问,有些依赖我怎么知道Maven的官方依赖中有没有呢,我怎么知道他有没有这个版本的呢,其实解决办法也很简单,大致可以分为两种:

1、去Google上面搜索,你可以这样搜索会更容易搜些:例如我们准备搜下spring的版本,可以这样写关键词的“maven spring repository”,这样搜索记录的第一条基本上就是的。

2、自己在Maven本地的仓库中建立依赖关系,默认是在.m2/repository文件夹下面,其中如何建立我不在详细介绍,按照默认的样式建就可以的,如果是自己生成的Jar依赖的话,就必须用这种形式了。

那行,下面我们首先进行Spring 所需的依赖配置,首先你在你的父Pom中的dependencies标签下面写上上述Spring的dependency,然后你执行命令mvn eclipse:clean eclipse:eclipse,然后在你的eclipse的目录结构中就会spring-2.5.6.jar这个依赖的(ps.当然这个你要在eclipse中配置一下你的path,这里我不在赘述),同样配置Ibatis也是一样的做法,下面我们首先把spring和ibatis整合起来,其实如何整合最好的教程就是spring自带的官方reference的,你可以参考上面的配置,七大概的位置实在中间层数据访问/使用ORM工具进行数据访问(当然我的是中文的reference)。

参考上面的配置我们即可配置一个demo,当然在这里我们需要主要的是xml文件我们为了统一,我们都会放在verticalmarket-config子工程下面,所以让我们在verticalmarket-dal中引用这些xml配置文件的时候我们要配置项目依赖的,其配置和配置第三方包依赖差不多,下面是我的依赖:

1 <dependency>  
2 <groupId>com.tkz.verticalmarket</groupId>
3 <artifactId>verticalmarket-config</artifactId>
4 <version>1.0</version>
5 </dependency>

至于其他的一些灵活配置,大家最好看Maven的官方文档资料,最重要的是多动手实践,这样子才会发现问题,更好的解决问题。

posted on 2011-12-29 11:21 小导 阅读(809) 评论(0)  编辑  收藏


只有注册用户登录后才能发表评论。


网站导航:
 

导航

统计

常用链接

留言簿

随笔档案

搜索

最新评论

阅读排行榜

评论排行榜