梦幻之旅

DEBUG - 天道酬勤

   :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  671 随笔 :: 6 文章 :: 256 评论 :: 0 Trackbacks
axis2-eclipse-codegen-wizard.zip  生成JAVA代码
axis2-eclipse-service-archiver-wizard.zip  发布webservice服务时使用


使用axis2-eclipse-codegen-wizard.zip 生成代码时,可能会提示错误.
解决办法如下(从网上抄摘):

  我在用Axis2开发WebService时,需要用到插件:axis2-eclipse-codegen-wizard.zip和axis2-eclipse-service-archiver-wizard.zip;
下载地址:http://apache.justdn.org/ws/axis2/tools/1_4_1/

   但是貌似这个地址提供的这个插件axis2-eclipse-codegen-wizard.zip缺少jar包,即如下:
"geronimo-stax-api_1.0_spec-1.0.1.jar"和"backport-util-concurrent-3.1.jar"。
由于缺少它们,导致出现"An error occurred while completing process -java.lang.reflect.InvocationTargetException"这样的错误。具体解决办法如下:
   下载"geronimo-stax-api_1.0_spec-1.0.1.jar"和"backport-util-concurrent- 3.1.jar"这两个jar包,之后将它们拷贝到Axis2_Codegen_Wizard_1.3.0文件夹中的lib目录下。

axis2_1.4.1版本中的lib包下有这两个jar,但是最新版axis2_1.5貌似缺少了这两个jar , 如果大家找不到这两个jar,下面提供目前可用的下载地址(如果地址不对,还请大家自己上网找去):
http://mirrors.ibiblio.org/pub/mirrors/maven/mule/dependencies/maven2/backport-util-concurrent/backport-util-concurrent%20/3.1/backport-util-concurrent-3.1.jar


http://dev.project.net/trac/pnet-community/browser/trunk/core/lib/geronimo-stax-api_1.0_spec-1.0.1.jar?rev=17737


然后修改Axis2_Codegen_Wizard_1.3.0文件夹下的plugin.xml,在
<runtime>中增加下面代码:
<library name="lib/geronimo-stax-api_1.0_spec-1.0.1.jar">
     <export name="*"/>
</library>
<library name="lib/backport-util-concurrent-3.1.jar">
      <export name="*"/>
</library>
重新启动eclipse或myeclipse即可。


若还不行,那么尝试改下这个版本,将plugin.xml中的version属性改为1.4.0,然后将
Axis2_Codegen_Wizard_1.3.0文件夹名改为Axis2_Codegen_Wizard_1.4.0;再重启eclipse即可。


我初次使用这个插件就存在这样的问题,网上查了资料,有相关的解决方案,不过有些仍然无法解决我当时遇到的问题。在http://mail-archives.apache.org/mod_mbox/ws-axis-user/200810.mbox/<48E46809.4020400@wso2.com> 这个地址里头说明了问题的所在。由于相关的资料较少,我写下这篇博客,为自己以后遇到同样的问题能够尽早的发现解决之道,也为大家提供一个参考。



posted on 2011-01-07 21:55 HUIKK 阅读(1978) 评论(0)  编辑  收藏

只有注册用户登录后才能发表评论。


网站导航: