emu in blogjava

  BlogJava :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  171 随笔 :: 103 文章 :: 1052 评论 :: 2 Trackbacks

终于要到一台新的项目服务器,把旧的东西一一挪到新服务器上来。在挪bugzilla的时候遇到一些问题。原来的服务器上面装的是2.18rc2版,使用的汉化模版却是2.18rc3版的,在老服务器上工作良好,但是在新服务器上中文版的模版无论如何都无法在IIS上发布出来,始终报告一个访问拒绝错误。去下了2.18rc3版的bugzilla过来,仍是相同的问题。本来就看着IIS很不爽了,试了几次不成功,换apache试试,结果和IIS抢端口了,干脆就把IIS给卸了。

跟着http://www.bugzilla.org/docs/win32install.html 一步一步来。做到最后发布的时候没有看到发布成功的首页,却看到了一个错误页面。进Program Files\Apache Group\Apache2\logs下面看error.log:

[Tue Mar 15 18:55:04 2005] [notice] Child 4488: Starting 250 worker threads.
[Tue Mar 15 18:55:10 2005] [error] [client 127.0.0.1] (OS 3)系统找不到指定的路径。  : couldn't create child process: 720003: index.cgi
[Tue Mar 15 18:55:10 2005] [error] [client 127.0.0.1] (OS 3)系统找不到指定的路径。  : couldn't spawn child process: C:/bugzilla-2.18/index.cgi
[Tue Mar 15 18:59:05 2005] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Mar 15 18:59:05 2005] [notice] Child 4488: Exit event signaled. Child process is ending.
[Tue Mar 15 18:59:06 2005] [notice] Child 4488: Released the start mutex

couldn't create child process —— 原来是无法创建子过程。看来是没有找到perl.exe。在这个问题上,安装指南说:

In order for ScriptInterpreterSource Registry-Strict to work, you also need to add an entry to the Registry so Apache will use Perl to execute .cgi files.

Create a key HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command with the default value of the full path of perl.exe with a -T parameter. For example C:\Perl\bin\perl.exe -T

Create a key HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command嘛,所以我就创建了HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI项然后在下面加了一个Command的key。不过既然出错了,不妨试试另一种理解,创建一个HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command项,再在下面的默认key上给了一个C:\Perl\bin\perl.exe -T 。重起apache。果然就ok了。应该这段文档的描述是有问题的。

最后上http://www.glob.com.au/sendmail/ 下载了sendmail,解压到C:\usr\lib下,在sendmail.ini里面修改smtp_server、default_domain、auth_username、auth_password(后面两项默认的被用分号注释掉,如果使用的smtp需要身份验证的话就去掉分号并填上正确的用户名密码),把服务器防火墙的25端口打开。试试改个bug,邮件就发出去了,大功告成。


[点击此处收藏本文]
发表于 2005年03月15日 7:44 PM

emu 发表于2005-04-06 5:18 PM  
今天在http://landfill.bugzilla.org/ppm 上发现了二月和三月各有一个文件更新:

MIME-tools.ppd 03-Feb-2005 20:36 532
MailTools.ppd 31-Mar-2005 21:28 400

应该是新版本的bugzilla正准备使用内置的邮件支持了吧。不过2.19的checksetup.pl还没有提示安装这两个包,不知如何使用。

此外,搞定了bugzilla运行在mysql 的 4.1以上版本时的身份验证问题。
在http://www.bugzilla.org/docs/win32install.html 上提及以下事实:
I've experienced a few issues with MySQL 4.1.x, so i recommend you install 4.0.x. When I have some time I'll investigate the issues (relating to database creation and authentication).

于是跟着提示找到了 http://dev.mysql.com/doc/mysql/en/old-client.html
这里有相信的解释和两个解决方法。一是:
mysql> SET PASSWORD FOR
-> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');

我试过了,不知为何更新不成功。
二是:
mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
-> WHERE Host = 'some_host' AND User = 'some_user';
mysql> FLUSH PRIVILEGES;
这样checksetup.pl就能够正确的连接到mysql了。

posted on 2005-05-18 14:17 emu 阅读(1757) 评论(0)  编辑  收藏 所属分类: 测试技术

只有注册用户登录后才能发表评论。


网站导航: